"The branch 'default' does not exist."

In the source code repository, I've somehow managed to wipe the default branch (unless Bitbucket is showing this in error). The repository is at:

https://bitbucket.org/mrshrinkray/roadkill/src/56648ce942407c712f761552d8f064175717567b/docs?at=default

Is there some way of rectifying this?

1 answer

1 accepted

If you did somehow manage to delete it, Bitbucket can't restore that branch for you. If you have the default branch locally, you could just try pushing it up to Bitbucket.

I thought it may have been a Bitbucket HG server issue, but it turns out someone who had branched, deleted the default branch somehow.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,774 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you