Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,177
Community Members
 
Community Events
176
Community Groups

getting 404 after upgrade

upgraded BitBucket server from 7.2.1 on Ubuntu 22.04 to 8.7.0. The server is up and running, SourceTree access functions but web access to port 7990 fails with 404. This worked before the upgrade. How do I remedy this? I have ssh access to Ubuntu. Is there anything I can edit on the server so it works again? Without web access I am pretty much lost.

1 answer

Still no success. Tried to re-install 8.7.0 but got the same result when connecting directl to port 7990 (which always worked before)

HTTP Status 404 – Not Found


Type Status Report

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Haven't been able to find a log file that could tell me more. So I have no clue what resource is not accessible. 

Where can I look? If all else fails I can rebuild the server, it is just a hassle and needs a bit of time which I really do not want to spend. As I wrote in my initial message git pull et. al. work so the server is alive. It's just the Web-interface that seams not to work.

Thanks for any help

---markus---

I guess the first thing to do is have a look in the Bitbucket server logs to see if anything is missing.

If you had an instance with the internal H2 DB you need a manual upgrade to a new format . 

Let us know your findings.

Ulrich

// Izymes

Unfortunately nothing in any log file. Access log shows regular SourceTree access (which succeeds) but does not do anything when I try a browser to access port 7990. Just that the browser returns the 404, nothing in any logfile though.

Will probably nuke the server anyway and start over with something else as Atlassian does not sell new BitBucket Server licenses anymore. I don't want to go cloud and DataCenter is waaaaaayyyy too expensive for a small shop as ours.

Thanks for your help

Fair enough. Good luck!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.7.0
TAGS

Atlassian Community Events