Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,049
Community Members
 
Community Events
168
Community Groups

app password is not working (with portainer)

Edited

I created a new password and unticked "private" from MY-REPO repository.

When I call this in portainer 

https://klauskobald:MY-APP-PASSWORD@bitbucket.org/klauskobald/MY-REPO.git

I get 

"Deployment error
unable to clone git repository: failed to clone git repository: reference not found"
when I curl the same url I get

Bitbucket Cloud recently stopped supporting account passwords for API authentication.

I am stuck since 6 hours - WHY!!!!????? Please help anybody!

But I can use the repo from within sourcetree with my regular user/pass.

1 answer

0 votes
Mark C Atlassian Team Sep 14, 2022

Hi @klauskobald

Thank you for reaching out to the community.

Based on the error message, it seems Portainer is not using your App password correctly as it works fine on the Sourcetree application.
If you're having issues with username and app password Git authentication in Portainer, an alternative is to probably use an SSH key.

You can follow this documentation on how to create a new SSH key: Set up an SSH key

Hope it helps and let us know if you have further questions about Bitbucket Cloud.

Regards,
Mark C

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events