Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,678
Community Members
 
Community Events
168
Community Groups

Why is duration time 4x higher in Standard-Tariff than in Free-Tariff?

Edited

Hi there,

 

today i run out of my 50 free build minutes from my Free tariff. Because i need some more minutes right now, i decided to upgrade to the Standard-Tariff.

Well the upgrade was fast...

But now i'm wondering, why my same size deployments need 4x longer than before???

I didn't changed the bitbucket-pipeline.yaml file... i just upgraded my tariff.

The "Paused" status was the point where my free minutes are over and i upgraded my package:

Bildschirmfoto 2021-09-20 um 20.21.51.png

2 answers

1 accepted

0 votes
Answer accepted

Hi Michael,

Were there any changes in the repo's source code that might have caused longer execution times? This is one possibility. It's difficult to say why this is occurring without checking the Pipelines logs, seeing what is executed, and comparing the builds before and after the upgrade.

My suggestion would be to create a ticket with Bitbucket Cloud support team to investigate this further. If there is an open support ticket, the support engineer working on your ticket will be able to access the builds and logs from our side and investigate this.

You can create a support ticket via https://support.atlassian.com/contact/#/, in "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as product. Please make sure to provide the URL of the repo in the details (the support ticket will be visible only to you and Atlassian staff, so your repo URL won't be publicly visible).

If you have any questions, please feel free to let me know.

Kind regards,
Theodora

Just for others with same problem/issue...

Here is a part from my solved support-ticket:

....

  • Free plan -
    • KataContainer enabled: true
    • apt-get update and install took around 10-12 seconds each
  • Standard/Premium
    • KataContainer enabled: false
    • apt-get update and install took around 45+ seconds each

Background, we started rolling out kata container for our customer as mentioned in our document - https://support.atlassian.com/bitbucket-cloud/docs/infrastructure-changes-in-bitbucket-pipelines/. When you were on Free plan, your workspace is using kata container.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events