Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to add reviewers to pull request

When creating or editing a pull request, I am unable to search for any users. When I attempt to do so I get a 401 error for the URL https://bitbucket.org/gateway/api/v1/recommendations. I am able to add reviewers from the "Recent:" list under the search box, but not able to search for other users to add them.

This occurs on multiple repositories. Other users using the same repositories also have the same problem.

1 answer

0 votes

Hi @Travis Bartlett ,

I would like to ask a few questions so we can better help you:

1. The PRs that have this issue, are they PRs from e.g. a branch of repo-A to another branch of the same repo-A?
Or are they PRs from a fork to the main repo?

In case they are PRs from a fork to a main repo, and the users you want to add as reviewers don't have access to the fork, you won't be able to add them while creating the PR, since they don't have access to the fork. However, once the PR is created, it is created in the main repo, and then you should be able to edit the PR and add the reviewers.

2. What browser are you using and which version? Can you reproduce the same issue in an Incognito/Private window of this browser, with all extensions disabled? This is to confirm whether the issue may be related to the browser or not.

Kind regards,
Theodora

Hello @Theodora Boudale ,

1. These are PRs from one branch to another within the same repos.

2. I am using chrome 89.0.4389.128 on Windows. The issue did not occur in an incognito window.

Logging out of my Atlassian account and then relogging in prompted me to re-verify my email, and now the reviewer list is working again. I and the other users I know were effected all log in using the "Continue with Google" option, so perhaps it was related to that connection.

Like # people like this

I was having the same issue! It had been occurring for me and a teammate since April 12, we were unable to add any reviewers to PRs. I'm using Chrome version 91.0.4472.19. I'd updated it a couple times over the past 2 weeks in hopes that would make a difference, as well as disabled my extensions, but I saw no difference. 

I logged out and then back in using the "Continue with Google" option and the situation appears to have resolved. 

Below is a screenshot of the problem occurring, in case that's useful.

Screen Shot 2021-04-26 at 6.25.39 PM.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

1,007 views 20 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you