Unable to access Organization Repos using App Password

wr_stan January 28, 2022

I created an app password on BitBucket (Cloud) and updated the information on Sourcetree using the online instructions provided. However, when I try to clone a remote repository to my local machine using Sourcetree, I am unable to see any repos from my organization workspace. I am only able to see repos in my personal workspace. Is there a setting or option I need to select?

4 answers

1 vote
keatwei February 4, 2022

Hi, i had the same issue.

- i create an App Password in my Bitbucket personal settings

- enter my username and App Password that generated

 

However, it still only shows my personal repository (without the workplace repo)

0 votes
jaysonids February 2, 2022

This seems to be an issue with the latest build of SourceTree - I am encountering the same issue and I did recreate an App Password, also tried the OAuth route with SourceTree and I'm not seeing any of my organization's repos

0 votes
Vishwas
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 1, 2022

Hey @wr_stan 

This issues might be due to the lack of workspace permissions at the time of creating an app password.

Regards,

Vishwas 

0 votes
Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 31, 2022

HI @wr_stan 

Thank you for contacting Atlassian Community. My name is Norbert and I'm a Bitbucket Cloud Support Engineer, it's nice to meet with you!

When I looked at your profile, I can confirm that indeed your account has access to an organization workspace.

To resolve this issue, can I ask you to remove your Bitbucket Cloud profile from SourceTree and once it's removed, try to re-add it once again?

Please let us know how it goes, we're here to help.

Best Regards,

Norbert
Atlassian Bitbucket Cloud Support

wr_stan January 31, 2022

Hi Norbert, 

Thanks for your suggestion but it did not work. I still get a red x on my initials when Show Organization Repos option is selected. The error states that "Your credentials lack one or more required privileged scopes." Not sure what that means.

Thanks.

Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 2, 2022

Hi @wr_stan ,

Thank you for your reply. 

The "Your credentials lack one or more required privileged scopes." means is that when you created the app password, you didn't include all the required scopes.

To make this work, can I ask you to create an app password, including these permissions?

Screenshot 2022-02-02 101307.png

Please let me know if it works with these permissions.

I'm looking forward to hear from you.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

wr_stan February 2, 2022

Hi Norbert,

I followed your instructions to create a new App Password and it works now. I also had to give it a new label. It wasn't working with the same name.

Thanks for your assistance.

Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 7, 2022

Hi @wr_stan

You're welcome, I'm glad to hear I was able to assist you :)

Have a great day ahead!

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

matsekberg March 10, 2024

I had the same problem, not seeing my other workspaces besides matsekberg.

Tried creating app password, with a new label and all the rights. Still no success, can only see matsekberg.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events