Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,904
Community Members
 
Community Events
176
Community Groups

Repository is over the size limit (4 GB) and will not accept further additions

Hello

I accidentally uploaded large files to the repository. Now I can't push new commits. I tried removing the file indexing, but that didn't help.
The size of the .git folder has not changed in any way.

How can I solve this problem?

1 answer

0 votes
Caroline R Atlassian Team Mar 14, 2022

Hi, @Oleg Vegera, welcome to the community! 

I found a repository that you have access to that was showing 4.8 GB, so I run the GC against this repo, but the size didn’t change. In this case, I have temporarily increased the repository size, so you can push the changes to the remote (without the large files). After that, please let me know so I can run the GC in the remote repo again. 

Looking forward to hearing from you. 

Kind regards,
Caroline

@Caroline R Thanks

I deleted these large files. Can I know how much the repository occupies now?

I see that these files are gone, but the size of the repository is still over 4 GB

Caroline R Atlassian Team Mar 14, 2022

Hi, @Oleg Vegera

Could you please confirm if after removing these large files you have pushed the changes to your remote repository? As I have increased the repo size to more than 4 GB, you should be able to push it now. Also, can you please share the workspace/repository name masked (with asterisks) so I can confirm we are referring to the same repo? 

Kind regards,
Caroline

Hi, @Caroline R 

We pushed a commit with large files removed. Now the repository does not contain these large files. But the size of the repository remains the same.

Repo name - Fitness Club 3D

Caroline R Atlassian Team Mar 18, 2022

Hi, Oleg. 

I ran a GC against this repository, however, the size didn't change, so it seems like the large files are still part of the remote repository. As you confirmed you have removed them from your local repo, could you please run a git push --force

Also, can you please run the following command locally and share its output with us? 

git count-objects -vH

Looking forward to hearing from you. 

Kind regards, 
Caroline 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events