Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,395
Community Members
 
Community Events
165
Community Groups

Not able to access bitbucket from browser as well as through terminal

Hi,

Since 25 August 2018, I am not able to access bitbucket via browser as well as not able to push code to the repository.

Initially, I thought it might be an internet issue, but bitbucket is not accessible only through my machine. My other team members could access it.

I checked if it is related to some internet issue, but all other sites that I access regularly for development purpose like StackOverflow, Github, etc are accessible. Even tested from different office locations and home. But the issue persists.

 

Need to know what is the issue? Could it be possible that bitbucket access is blocked from my system?

 

Please let me know what could be the solution for this as I am unable to update my repository since 25 August 2018.

 

Thanks & Regards,

 

Rahul Shelke

Cofounder & CTO

mycuteoffice.com

3 answers

1 accepted

0 votes
Answer accepted

I solved the issue myself. The issue was with the DNS configurations. 

As per the last update from bitbucket, a year and a half back, they suggested to force git to use IPV4 by adding following entry to /etc/hosts file:

 

104.192.143.2 bitbucket.org

 

The above line was causing the issue after the latest update to bitbucket in the last week. Once I removed that entry, everything started to work smoothly.

I was experiencing this exact same problem but I did not have 104.192.143.2 bitbucket.org in my /etc/hosts file.

What fixed this for me is by adding the Google DNS servers to my network settings:

Screen Shot 2021-09-24 at 11.59.00 AM.png

Make sure to click "Apply" at the bottom of the Network settings screen after pressing OK.

I tried this solution and it worked. Not sure why it's happening though. 

Just checked using proxy VPN, it allows to access bitbucket in the browser. 

Then why am I not able to access it in the terminal to push code? also why normal browsing does not work?

Hi, even I am not able to access the bitbucket through terminal as it is throwing me an error as " unable to access ".

Can anyone help me on this?

Check your /etc/hosts entries. 

and refer my accepted answer, that might help.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,239 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you