Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,560
Community Members
 
Community Events
165
Community Groups

Need git gc on remote repository

Hello,

I have a private repository that has hit the size limit and I am unable to reduce the size with the options described at the suggested https://confluence.atlassian.com/x/xgMvEw link. I have tried enabling the Labs feature and reset with the force push (the latter of which has worked for me in the past, but did not work this time). I am unable to file a ticket with support for this issue as described as it directed me to the community support, please assist.

1 answer

1 accepted

0 votes
Answer accepted

Hi @lwallace,

I can see in our system that your personal Bitbucket workspace owns one repository over 2 GB, so I went ahead and ran a git gc on that. Its size now is 75.5 MB. I'm not sure if this is the repo you are referring to though.

Your Bitbucket account is a member of several other workspaces, so I don't know if your request concerns a repo owned by any of these other workspaces instead? If so, could you let me know the workspace-id/repo-slug of the repo, but masked (replace some characters with asterisks, like **p**g/*a***j***n), so I can locate it and run a git gc on it?

Kind regards,
Theodora

Thank you Theodora, the repository that needs a git gc is bitbucket.org/NR*ad***/e**rb**_*ar

Hi @lwallace,

Thank you for your reply.

I ran a git gc on this repository and its size now is 133.6 MB. Does this agree with the size of your local repo?

Please feel free to let me know if things are ok now and if you need anything further.

Kind regards,
Theodora

Yes, I was able to push my changes now, thank you!

Lauren

Like Theodora Boudale likes this

Thanks for the update Lauren, and you're very welcome!

Please feel free to reach out if you ever need anything else.

Kind regards,
Theodora

Hello Theodora, not sure if I need to create a new issue but I am having the same issue on another repository, this time the repository is bitbucket.org/nr*ec*/ec*nb**_*ar, could you run a git gc for me on this one please?

 

Thank you!

 

Lauren

Caroline R Atlassian Team Feb 23, 2022

Hi, Lauren!  

We generally encourage users to create a new question for their issue instead of posting on a previous question because 1) the root cause and resolution may be different for each case 2) a question can become cluttered and difficult to follow if we try to troubleshoot multiple users' issues in it. So, I would like to ask if you could please create a new question for your issue. 

Please feel free to let me know if you have any questions. 

Kind regards, 
Caroline 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,231 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you