Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Deployment to repository downloads

Edited
I followed this
image: maven:3.3.3 pipelines: default: - step: script: - pipe: atlassian/bitbucket-upload-file:0.1.2 variables: BITBUCKET_USERNAME: $BITBUCKET_USERNAME BITBUCKET_APP_PASSWORD: $BITBUCKET_APP_PASSWORD FILENAME: "app/build/outputs/apk/debug/application-debug.apk"




1 answer

0 votes
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 03, 2021

Hi Christopher and welcome to the community.

Are you getting any errors when using this pipe? Or do you have any questions regarding adding variables to your repository? It's a bit unclear what the issue is.

The public repository for this pipe is here:

and it includes an explanation of the different variables as well as more examples on how to use the pipe. The latest version of the pipe is 0.3.2, so I would suggest using that instead of version 0.1.2. Please note that you will also need to replace the value of FILENAME with the path of the file you want to upload.

If you get errors when using this pipe, it would be useful to have the full output of the pipe command from the log of your Pipelines build (please feel free to sanitize any private/sensitive info in the output, prior to sharing it here).

Please feel free to also let me know if you have any questions.

Kind regards,
Theodora

Hi Theodora,

Sorry, I thought I edited as answered.

I edited the post to say how I solved the issue, I had not made the variables in the repository so it was not working. Once I made the variables with the appropriate information it worked as intended.

Thanks.

Like Theodora Boudale likes this
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 05, 2021

Hi Christopher,

Thanks for the clarification, I did not realize that your last comment regarding the variables was how you solved it. I'm glad it's working as expected now!

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events