Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cloning Error: Could not resolve host bitbucket.org

Hello,

I am trying to clone a bitbucket repository and got the below error message.

I am doing it on a Windows machine.

I tried many different ways to see if it works.

1) Visual Studio Code: Same error, error screenshot below

2) Brackets: Same error, error screenshot below

3) Source Tree : Same error, error screenshot below

4) Git Hub: Same error, error screenshot below

image.png

However, when I tried the same repository on mac pro with Brackets, it worked fine.

Is it because of proxy or DNS or some thing?

I put so much effort and could not get rid of this, I really appreciate your suggestions or tips to fix this.

Thank you so much :)

Regards,

Krishna

3 answers

1 vote
jredmond Atlassian Team Mar 11, 2018

Yes, this does look like a DNS issue. Can you reach Bitbucket from a browser on that system?

Yes, James,

I could not even get any response from www.google.com.

Error: "Ping request could not find host www.google.com. Please check the name and try again."

Any trick or tip to get rid of this?

Thanks for your response.

 

Regards,

Krishna

Hello James,

Which is my URL? Sorry, I am not sure.

The one in the URL area of the browser? I am able to access the below one from the same machine.

https://bitbucket.org/krishnabasvani/panxxxxxxrepo/src/master/

or copied from the clone option? but not this one.

https://krishnabasvani@bitbucket.org/krishnabasvani/panxxxxxrepo.git

Thank you!

Regards,

Krishna

jredmond Atlassian Team Mar 12, 2018

Both of those go to bitbucket.org, but the second one includes the username. That isn't necessary for browser access, as your user session is managed by the login process.

Like Dmitry Kazhenkin likes this

I had same error and below worked for me.

$ git config --global user.name "Emma Paris"
$ git config --global user.email "eparis@atlassian.com"

I set user name and password same as of my bit bucket account.

Since you are using windows, you might have to use different commands but key point here is to configure git account.

jredmond Atlassian Team Sep 23, 2019

This is not related to the original question. If your DNS resolution is broken, then changing git config parameters will not resolve that.

That did solve the problem for me, too. It might be an issue with git.

Check your internet Connection and DNS. if internet is working verify your company/router is not blocking the access to the domain

Hello Pavan,

I can access all the websites through browser and I think there is no problem with internet. I do not know how to check that if company is blocking access to a domain.

When I ping from command prompt, it does not allow pings to any website.

Thank you!

Regards,

Krishna

i guess your firewall or antivirus is the culprit

Yes Pavan,

 

Looks like either firewall or antivirus.

Thank you!

 

Regards,

Krishna

What if i got this same unable to resolve host error while pulling data into remote desktop through SSH? Would it be problem by local installed antivirus? because I don't have any antivirus on remote.

Like Evgeniy Gurinov likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you