some screens do not display correctly with bamboo 5.9.4

hy,

I just installed the last version of bamboo (5.9.4) And some screens do not display correctly in all navigators (IE, Chrome and firefox)


Have you any ideas why ?

 

   Best regard

image2015-9-15 12:7:10.pngimage2015-9-15 12:9:1.png

5 answers

1 accepted

This widget could not be displayed.

Do you have any 3rd party add-ons installed?
I've seen this issue in the past when an incompatible add-on was installed, often the "Marvelution Bamboo Sonar Tasks Plugin".
Disable any 3rd party add-ons, and clear your browser cache, to see if that solves the problem.

Hy Rene, You are find my problem. We have still temporarily "Marvelution Bamboo plugin Sonar plugin Tasks" activated before migrating to the plugin " Sonar for bamboo . " Thank you for your help

This widget could not be displayed.

Hello Francis,

Thank you for your question.

  1. check if there is/are plugin(s) to be updated under "Bamboo administration >> Add-ons >> Manage add-ons"
  2. disable plugin(s) under "Bamboo administration >> Add-ons >> Manage add-ons >> User-installed add-ons"
  3. clear the browser's cache
  4. visit the Bamboo login screen once again, please.
    It might be the case you will need force refresh on your web browser, by holding Ctrl+Shift+R 

If you find this answer useful, I would kindly ask you to accept it so the same will be visible to others who might be facing the same issue you have inquired.

Thank you for your understanding.

Kind regards,
Rafael P. Sperafico
Atlassian Support

This widget could not be displayed.

Hi @Francis REAT, 

Could you please elaborate on the environment you are running? What operating system are you using and which versions of IE, FF, Chrome did you try? If you dont mind, please raise a bug report here with the information

https://jira.atlassian.com/browse/BAM

Thank you!

Sigge, QA Bamboo

Hi @Sigge Birgisson , thank you for your answer. The Bamboo instance run on server windows 2008 R2 Service pack 1. I tested with Chrome - Version 45.0.2454.85 m FF - version 40.0.3 IE - version 11.0.9600.1815 Best regard

This widget could not be displayed.

Hello Rafael Thank you for your help. I verified the 4 points. Everything is OK. But the problem stays. I try to visit the bamboo login screen since a new machine where I never opened this URL with IE (no cache), and the problem stay too. Can you try to open this URL https://pid.hardis.fr/bamboo and tell me if you have my problem ? Best regard

Hello Francis, are you running Bamboo behind Apache, Nginx, IIS or other?

hello Rafael, yes Bamboo is running behind Apache (version 2.4).

Do you have any redirect in place (Apache) or have you updated "<bamboo-install>/conf/web.xml" some how?

No change in <bamboo-install>/conf/web.xml file In <bamboo-install>/conf/server.xml we have that : <Service name="Catalina"> <Connector port="8085" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="443" acceptCount="100" disableUploadTimeout="true" secure="true" scheme="https" proxyName="pid.hardis.fr" proxyPort="443" /> <Engine name="Catalina" defaultHost="localhost"> <Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true"> <Context path="/bamboo" docBase="${catalina.home}/atlassian-bamboo" reloadable="false" useHttpOnly="true"> <Manager pathname=""/> </Context> </Host> <Valve className="org.apache.catalina.valves.AccessLogValve" resolveHosts="false" pattern="%a %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot;"/> </Engine> </Service> And in <apache-install>/conf/extra/httpd-ssl.conf file we have : <VirtualHost *:443> HostnameLookups off DocumentRoot "c:/Apache24/htdocs" ServerName pid.hardis.fr ServerAdmin admin@hardis.fr ErrorLog "c:/Apache24/logs/sslpid-error.log" # SSL Engine Switch: # Enable/Disable SSL for this virtual host. SSLEngine on SSLProxyEngine On SSLCipherSuite AES128+EECDH:AES128+EDH SSLCertificateFile "C:/Apache24/conf/certificats/www.hardis.fr.cer"; SSLCertificateKeyFile "C:/Apache24/conf/certificats/www.hardis.fr.key"; SSLCertificateChainFile "C:/Apache24/conf/certificats/server-ca.cer" <FilesMatch "\.(cgi|shtml|phtml|php)$"> SSLOptions +StdEnvVars </FilesMatch> <Directory "c:/Apache24/cgi-bin"> SSLOptions +StdEnvVars </Directory> BrowserMatch "MSIE [2-5]" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0 RewriteEngine On ProxyPreserveHost On ProxyRequests Off SSLProxyVerify none SSLProxyCheckPeerCN off SSLProxyCheckPeerName off SSLProxyCheckPeerExpire off <Location /bamboo> ProxyPass http://vmhardisforge3.hardis.fr:8085/bamboo flushpackets=on ProxyPassReverse http://hardisforge3.hardis.fr:8085/bamboo # Order Deny,Allow # Deny from all # Allow from .hardis.fr </Location> </VirtualHost>

This widget could not be displayed.

Hello Francis,

Thank you for your update.

Could you please update "<bamboo-install>/conf/server.xml" connector to be:

&lt;Connector port="8085" 
     maxThreads="150"
     minSpareThreads="25"
     enableLookups="false"
     maxHttpHeaderSize="8192"

     protocol="HTTP/1.1"
     connectionTimeout="20000"
     useBodyEncodingForURI="true"
     redirectPort="443"
     compression="on"
     compressableMimeType="text/html,text/xml,text/plain,text/css,application/json,application/javascript,application/x-javascript"
     secure="true"
	 scheme="https"
	 proxyName="pid.hardis.fr"
	 proxyPort="443" /&gt;

And update Apache's VirtualHost as per following:

&lt;VirtualHost *:443&gt;
	ServerName pid.hardis.fr
	ServerAdmin admin@hardis.fr

	&lt;Proxy *&gt;
		Order deny,allow
		Allow from all
	&lt;/Proxy&gt;
	ProxyRequests		Off
	ProxyPreserveHost	On
	
	ProxyPass 			/bamboo	http://vmhardisforge3.hardis.fr:8085/bamboo flushpackets=on
	ProxyPassReverse	/bamboo	http://vmhardisforge3.hardis.fr:8085/bamboo

	ErrorLog "c:/Apache24/logs/sslpid-error.log"

	#   SSL Engine Switch:
	#   Enable/Disable SSL for this virtual host.
	SSLEngine on
	SSLProxyEngine On
	SSLCipherSuite AES128+EECDH:AES128+EDH
	SSLCertificateFile "C:/Apache24/conf/certificats/www.hardis.fr.cer";
	SSLCertificateKeyFile "C:/Apache24/conf/certificats/www.hardis.fr.key";
	SSLCertificateChainFile "C:/Apache24/conf/certificats/server-ca.cer"

	&lt;FilesMatch "\.(cgi|shtml|phtml|php)$"&gt;
	    SSLOptions +StdEnvVars
	&lt;/FilesMatch&gt;
	&lt;Directory "c:/Apache24/cgi-bi"&gt;
	    SSLOptions +StdEnvVars
	&lt;/Directory&gt;
	BrowserMatch "MSIE [2-5]" \
	         nokeepalive ssl-unclean-shutdown \
	         downgrade-1.0 force-response-1.0
&lt;/VirtualHost&gt;

Please, refer to Securing Bamboo with Apache using SSL documentation for further information.

I have noticed your ProxyPassReverse (hardisforge3.hardis.fr) is set up to a different DNS from ProxyPass (vmhardisforge3.hardis.fr). Could you please review them and make the changes if required?

Kind regards,
Rafael P. Sperafico
Atlassian Support

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

266 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you