Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

bamboo installation is taking a lot of time


2 answers

2 accepted

0 votes
Answer accepted
Daniel Ebers
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jan 08, 2022

Hi @Shafeequr Rehman Mohammed

generally speaking it >might< be easier to use a database like, for example, PostgreSQL than the integrated H2 database.

Success on the H2 database varies, according to reports here in Community. It is reported to be fine in most cases for short tests but not for a production system.

Installing a database like PostgreSQL is not that hard and could rule out the H2 database as a source of trouble.


Thanks @Daniel Ebers . Yes, I was trying bamboo setup Bamboo for the first time using express installation method that uses H2, so this was the error. I tried connecting to external database and it did work.

0 votes
Answer accepted

Ola @Shafeequr Rehman Mohammed ,

Send me your <installation bamboo>/logs, compress in zip file & <bamboo home>/logs, compress in zip file to, let's check what happen with your bamboo ?

Hi @Daniel  , sorry I had terminated my EC2 instance where bamboo was installed and configured.

However, I had these logs captured:-

java.lang.NoClassDefFoundError: Could not initialize class org.h2.value.CompareMode
at org.h2.engine.SessionRemote.<init>(
at org.h2.jdbc.JdbcConnection.<init>(
at org.h2.jdbc.JdbcConnection.<init>(
at org.h2.Driver.connect(
at com.mchange.v2.c3p0.DriverManagerDataSource.getConnection(
at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(
at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(
at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool$1PooledConnectionResourcePoolManager.acquireResource(
at com.mchange.v2.resourcepool.BasicResourcePool.doAcquire(
at com.mchange.v2.resourcepool.BasicResourcePool.doAcquireAndDecrementPendingAcquiresWithinLockOnSuccess(
at com.mchange.v2.resourcepool.BasicResourcePool.access$700(
at com.mchange.v2.resourcepool.BasicResourcePool$
at com.mchange.v2.async.ThreadPoolAsynchronousRunner$
2022-01-03 13:13:19,044 WARN [C3P0PooledConnectionPoolManager[identityToken->1br9s4lam8wd68zz8dtaq|7115986]-HelperThread-#1] [ThreadPoolAsynchronousRunner] An Error forced the closing of Thread[C3P0PooledConnectionPoolManager[identityToken->1br9s4lam8wd68zz8dtaq|7115986]-HelperThread-#1,5,main]. Will attempt to reconstruct, but this might mean that something bad is happening.
java.lang.NoClassDefFoundError: Could not initialize class org.h2.value.CompareMode
at org.h2.engine.SessionRemote.<init>(

Like # people like this

Thanks @Daniel  

Ill have a look at the solution provided. :)

Thank you so much @Daniel  , the solution indeed worked!!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events