Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,165
Community Members
 
Community Events
176
Community Groups

XSRF token error with IIS reverse proxy

Bamboo Server v7.2.4 / IIS 10

Setup a reverse proxy in IIS so my team can access our Bamboo instance on a user-friendly URL. This is working perfectly everywhere except for the Deployments page where I see this error:

1.PNG

The release statuses never load, showing the "waiting" spinner indefinitely.

In the Network tab of dev tools, I see 403 errors for each access to [server-name]/rest/api/latest/deploy/dashboard/status -- the server's response for each of these is "XSRF check failed".

I have tried unchecking "Enable XSRF Protection" in Security Settings and this has no effect.

Can anyone advise on specific IIS settings to pass along CSRF tokens correctly? I do not need a general setup guide for ARR/reverse proxies; this is a more specific error.

Alternatively, can anyone advise on truly disabling XSRF protection in Bamboo? Options in Security Settings have not been effective.

1 answer

1 accepted

0 votes
Answer accepted

I was missing a step in configuring Bamboo behind a reverse proxy. For anyone else running into a similar issue - and similarly having trouble finding the right docs - have a look here:

https://confluence.atlassian.com/bamkb/securing-bamboo-behind-nginx-using-ssl-829075298.html

In my case, I had configured IIS as the reverse proxy and everything (except the Deployments page) was working well. Deployments showed the error in the upper right (annoying because it blocks the menu) and failed to complete any of the async calls to get environment statuses.

From the linked doc, I only had to add Step 1: Configure the Tomcat Connector to get it working 100%. I commented out the original Connector for port 8085 and replaced it with the one on this page; restarted Bamboo through services.msc; and suddenly life was good.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events