Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Windows 10 Agent Environment Variables Problem

I'm having some issues with environment variables not being properly set when executing a plan that runs on a Windows 10 agent. Specifically, when I remote into the agent and test the build scripts I've set up, the environment variables don't match the results of an echo when running my plan.

I'm using cmake and cl.exe to build our project. For the compilation step, I've configured a "script task" that runs with cmd.exe.  At the beginning of the script, I initialize the command line build environment by calling vcvars64.bat. This initializes a number of environment variables that are necessary for the build to succeed (%PATH%, %LIB%, %LIBPATH%, %INCLUDE% to name a few). My issue is that the environment variables don't match the results of my remote session when I call vcvars64.bat from the script task (confirmed via echo). Does anyone have any ideas as to why I am seeing this inconsistency? I would prefer to not have to manually set these environment variables as the vcvars64.bat script is supposed to automatically set them.

NOTE: I'm running the bamboo remote agent as a service, and I've ensured that it is running as the "bamboo" user as opposed to the "system" user.

1 answer

1 vote

Interactive and non-interactive user sessions in Windows do not behave the same way when it comes to environment variables. You need to adjust your script accordingly.

For now, I'm setting the environment variables in my task to match the environment variables for my interactive session. Would you happen to know if there's any way to have the non-interactive session behave similarly to the interactive session?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.2 is here!

I'm happy to announce that Bamboo 7.2 has been released and it’s overflowing with awesome new features. This will be the last major Server release before the launch of Bamboo DC. Bamboo logs We...

474 views 5 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you