Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why won't Bamboo scan for specs? Edited

I've followed all the instructions from the Atlassian wiki for creating a Bamboo Specs repo (using Java specs). I can test and publish locally, but when I set up the repo as a Specs Repo, I only ever see "This repository was never scanned". When I click the Scan button, a message comes up saying that scanning started, but then nothing happens, and I don't see any conclusive errors in the logs. I tried using Docker, and not using Docker. I do have Docker installed on the machine instance (we're running in AWS), but don't see any images listed when I run the "docker images" command over SSH.

I'm not sure what further steps I should take to troubleshoot this. I've already tried all the suggestions in the first item of https://confluence.atlassian.com/bamboo/bamboo-specs-troubleshooting-938844477.html

2 answers

1 accepted

2 votes
Answer accepted

Do you have bamboo-specs folder in a root of your repository?

Here's a screenshot of what the project looks like:

2019-04-23_10-50-30.png

Should "src" be named "bamboo-specs"? I created the project with the Maven Archetype the way the tutorial had me do.

This is my pom.xml's contents (sorry, pasting stripped indentation):

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>

<parent>
<groupId>com.atlassian.bamboo</groupId>
<artifactId>bamboo-specs-parent</artifactId>
<version>6.7.1</version>
<relativePath/>
</parent>

<groupId>com.orion.EndurPlugins</groupId>
<artifactId>integration</artifactId>
<version>1.0-SNAPSHOT</version>
<packaging>jar</packaging>

<dependencies>
<dependency>
<groupId>com.atlassian.bamboo</groupId>
<artifactId>bamboo-specs-api</artifactId>
</dependency>
<dependency>
<groupId>com.atlassian.bamboo</groupId>
<artifactId>bamboo-specs</artifactId>
</dependency>

<!-- Test dependencies -->
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<scope>test</scope>
</dependency>
</dependencies>

<!-- run 'mvn test' to perform offline validation of the plan -->
<!-- run 'mvn -Ppublish-specs' to upload the plan to your Bamboo server -->
</project>

All content of your repo root should be at bamboo-specs folder

/-bamboo-specs
|-src
| \java
|-pom.xml
Like Dov Frankel likes this

Oh... ok. I'll give that a shot. Is that documented and I just missed it? If so, can you please point me there to make sure I didn't miss anything else?

https://confluence.atlassian.com/bamboo/tutorial-bamboo-java-specs-stored-in-bitbucket-server-938641946.html

Note: You must create Bamboo Specs in the bamboo-specs directory, under the repository root.

Like Dov Frankel likes this

It is important to notice that the java file should be at the root folder with the rest of the content inside bamboo-specs. Don't create bamboo-specs with the java specs in it and then have separate folders.

 

@Alexey Chystoprudov For 6.8 the error logs and success logs are empty.

@Dov Frankel Did you ever figure this out? I'm having the same issue and I can't find any Atlassian documentation that discusses the naming conventions for spec files and how the scan process locates them.

Yes, if you look at the accepted answer thread, you'll see the whole project needs to be inside a `bamboo-specs` directory. That's the piece I was missing.

Thanks. I'm not sure how I missed that.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

182 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you