When clicking "Application Links" in bamboo a page not found error is returned.

Hi!

While debuging why the bamboo builds are not showing up on jira I detected several problems with bamboo

1) On the plan details the Issues tab is missing

2) When clicking on Administration ->Application Links, a 404 error is returned.

The URL in cause is:

http://<my domain>:8085/plugins/servlet/applinks/listApplicationLinks

or

http://<my domain>:8085/plugins/servlet/applinks/listEntityLinks/com.atlassian.applinks.api.application.bamboo.BambooProjectEntityType/AM

I believe this might be the cause the builds aren't showing up on Jira. I have succesfuly integrate both applications from the Jira side, with a two-way link. Both incoming and outgoind authentication are set to "Trusted application". I have reasonable trust that the integration is well configured.

Does anyone have an idea on what's wrong or missing with Bamboo? These 404 errors suggest some files / plugins are missing...

Many thanks!

7 answers

1 accepted

This widget could not be displayed.

James, good luck getting someone to answer you.

This widget could not be displayed.

My problem has been identified and resolved. The issue was caused by the installing of Java 7 in the default directory c:\Program Files. i could see that java 7 was used under the System Information tab.

Two ways to solve this. DO NOT install java 7 in the default directory. Choose another directorylike C:\Java7

If you already have Java 7 installed in the default dir, then update the wrapper.conf file,

# Specify which version of java you use to run Bamboo

#

wrapper.java.command=java

change to wrapper.java.command=C:\Program Files\Java\jdk1.6.0_23\bin

worked for me

wrapper.java.command=C:\Program Files\Java\jdk1.6.0_23\bin\java

This widget could not be displayed.

Which JIRA version is it?

Sorry, it's Jira v4.4.3 and Bamboo 3.3.2

This widget could not be displayed.

I have the same problem.

Using Jira v4.4.4#664-r167664 and Bamboo 3.4.2 build 2810

I have this problem only if Bamboo is installed and started as a Windows Service. I have tried to stop the service and start it in a console window and the problem has fixed. I could setup the application link between Jira and Bamboo and I could see the Bamboo gadgets in Jira Dashboard.

Then I tried to stop Bamboo and start the Windows service again, but now the problem came back, and a gadget I configured in my Dashboard now says "The resource http://bambooserver:8085/rest/api/1.0/currentUser, cannot be found."

Adding problem to problem, even when I had Bamboo started in a console window, I could not have the gadget working, because I had problem with authentication.


This widget could not be displayed.

I'm having the same problem... did you ever find out what the problem was? Using Jira v4.4.5#665 and Bamboo 4.0.1 build 2907 on Windows.

Problem still occurs. Bamboo version 4.4.1

I'm seeing this problem too on Bamboo version 4.4.3. Did you find a solution?

This widget could not be displayed.

Same problem here.

This widget could not be displayed.

After a reboot and restart, I now have the same problem. Using Bamboo 4.4.5 and JIRA 5.2.3

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

98 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you