Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Running Bamboo Server over AWS EC2 instance suddenly not respondin

Edited

I have setup Bamboo server over AWS EC2 instance using https://confluence.atlassian.com/bamboo/running-bamboo-server-in-aws-858705568.html

Bamboo Server Setup

EC2 Instance Type t2.small
SSL Certificate is not installed as of yet

1. Server setup was all good
2. Bamboo UI was working via EC2 instance public link
3. Server SSH also working
4. Installed following extra components to the EC2 Instance
- Node 12 LTS
- Docker
- AWS CLI
5. Once docker is installed need to give access to bamboo user for docker service else docker image will not be created via bamboo.

https://confluence.atlassian.com/bamkb/docker-task-permission-denied-887749337.html

6. Was able to set up my desired plan with required jobs
- GIT code checkout via bitbucket repo
- Script Command (npm install, other direct command)
- Docker (running an image and performing some functionality as part of it)
7. The build was working fine for many days


Initial Issue
Identify issue related to memory,i.e. after a few days memory is all used. So investigated it out and identify that my Docker Image was creating Volumes which where dandling and not in use any more.
So to fix it up and have removed all the dandling volumes and added another cleanup job as part of my bamboo plan to clean up docker dandling volumes.

After the above issue was fixed my Bamboo Server was working for a week or so and plan was processing successfully.

Current Issue
Everything was working fine and we feel good with Bamboo, so wanted to move to purchased licence, which we did. But just before changing it to the server our Bamboo Server started behaving strangely.
- Bamboo Server is not accessible via Public Link, just keep loading and server is not reachable
- SSH to the server was also not working

Tried Following

  1. Reboot instance from AWS EC2 Console but it was of no use
  2. Stop and Start EC2 instance. After this, i could SSH to the instance but as i try to open Bamboo Ui via public link again its stuck and again cant ssh instance.
    Tried the process again and reviewed logs, all the installed services, instance memory but everything looks fine.
  3. Changed instance type to t2.large, but still saving behaviour as explained as part of 2

Not sure why its happening, would really appreciate if you could point out to potential issues so that i can try to fix it up.

- Inam Alam

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center is here!

G’day Bamboo customers, The wait is over! Bamboo Data Center edition you have been asking for is finally here! This self-managed enterprise offering of Bamboo has the resilience, reliability, and s...

501 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you