Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Remote agent suddenly became offline, why ?

Edited

My remote agent suddenly become offline on the 7th of November, after working flawlessly for a while. Those are the debug steps I've taken so far. Nothing worked. I'll be grateful for some help, because now I'm a bit lost.

  • Reboot server and agent
  • Check firewalls to be sure 54663 is still opened for both server and agent. Taking inspiration from another post I saw in the community, I've been able to successfully call "telnet server-bamboo 54663" and connect
  • Check the workaround for SSL secure connection is still in the configuration
  • Reinstall the remote agent from scratch
  • Check that bamboo is still v6.10.3 and that nothing was changed
  • Check java is still OpenJDK v1.8.0 
  • Check bamboo's certificate is not expired
  • Revert secure connection to non secure (ssl://    ->    tcp:// ) for remote agent
  • Reinstall the remote agent from scratch

The error with secure connection was:

ERROR [ActiveMQ BrokerService[bamboo] Task-20] [TransportConnector] Could not accept connection from tcp://AGENT-IP:7756 : javax.net.ssl.SSLException

ERROR [ActiveMQ BrokerService[bamboo] Task-33] [TransportConnector] Could not accept connection from tcp://AGENT-IP:37703 : javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake

Now without secure connection:

 WARN [ActiveMQ Transport: tcp:///213.200.250.6:30445@54663] [Transport] Transport Connection to: tcp://AGENT-IP:30445 failed: java.io.EOFException 

EDIT : the remote agent is now working with TCP. The workaround flag for SSL needs to be removed from the Broker client URI. Still don't know why the secure version is not working.

EDIT 2 : just tried the secure connection without the workaround flag, didn't work

EDIT 3 : it almost looks like with or without the workaround flag in secure mode (ssl://), the result is the same. Now that I've tested without the flag, it seems to me that the workaround is not effective anymore, because the error messages look the same. But I have no idea why it would stop working suddenly.

1 answer

I am having the same issue. Anyone from atlassian?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center is here!

G’day Bamboo customers, The wait is over! Bamboo Data Center edition you have been asking for is finally here! This self-managed enterprise offering of Bamboo has the resilience, reliability, and s...

501 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you