Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,610
Community Members
 
Community Events
176
Community Groups

Redhat openjdk 1.8.0.272.b10-1 breaks tls in bamboo 7.1

We've been using bamboo with tls on port 8443 for years.  Redhat released openjdk 1.8.0.272.b10-1.el7_9 and when we upgraded our bamboo server to it, none of the agents or browsers could communicate to 8443.  We are seeing a "err_ssl_protocol_error" message in chrome and the agents report "javax.net.ssl.sslexception: unsupported or unrecognized ssl message" in their logs.  We do have a proxy in front on port 443 that proxies to 8443 and that still works fine.

I've tried modifying java.security file settings but nothing seems to be making a difference.  My concern is that I'm going to see the same issue with our other Atlassian servers.

Also, I upgraded to bamboo 7.1.4 but forgot to specify the bamboo.home directory in atlassian-bamboo/WEB-INF/classes/bamboo-init.properties.  When I went to the bamboo server on port 8443, it displayed the web page showing me the diagnostic page that shows the java version check and the bamboo.home setting and how to fix it so the tls issue happens after I specified the bamboo.home directory.

Had anyone else seen issues with upgrading to that version of openjdk on RHEL7?

Thanks

2 answers

1 accepted

3 votes
Answer accepted

Hi @doug_curtis,

It looks like you have stumbled onto this bug.

Glad to see that you managed to fix it by downgrading Java. If this was not an option, I was going to suggest the workaround proposed by my colleague in the bug report above.

Good news is that this has been fixed in Bamboo 7.2.0 already (that is yet to be released as of today).

Cheers,
Jey

Thanks for this.  This seems exactly like what I'm running into.  I'll play around with options specified in the bug report to verify.

Thanks again!

That's definitely what it was.  Disabling the RSASSA-PSS signature algorithm fixed the issue.  At least now if I HAVE to upgrade to u272, I have a solution for it.

Thanks for the quick response.

Jeremy Owen Atlassian Team Nov 19, 2020

G'day Doug,

We're fairly confident you won't run into this with any other Atlassian products as it relates to a certain Bamboo dependency and how it's loading crypto providers. 

Cheers,

Jeremy

That's good news.  I was going to add RSASSA-PSS on my other Atlassian servers as a precautionary measure but I'm glad that it's probably not necessary.

0 votes
edwin Rising Star Nov 19, 2020

Hi @doug_curtis ,

Please confirm and test the following.

  1. Custom configurations were migrated from the previous installation.
  2. Port 8443 is enabled in the server.xml .... Bamboo listens on 8085 by default.
  3. Unrecognized SSL message, plaintext connection? 

1.  Yes they were.  I only upgraded from 7.1.1 to 7.1.4 to see if it fixed the issue.  The only upgrade that broke bamboo was the openjdk upgrade.

2.  Yes.  We have a connector specified in the server.xml for port 8443 that references a keystore with the password.  This worked fine before the openjdk upgrade.

3.  I saw this in my searches and tried it but it didn't fix the issue.

 

I should also note that downgrading openjdk fixes the issue.  We don't run any custom jdk settings.  I've only started trying different jdk settings to see if it affects it.  It seems like either a TLS protocol or cipher issue.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events