Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,185
Community Members
 
Community Events
176
Community Groups

PKIX path building failed

Edited

Hi,

i have imported my custom certificate with intermediate certificate into my truststore which is set by: -Djavax.net.ssl.trustStore=/var/lib/bamboo/cacerts

 

and:

/usr/lib/jvm/java-8-oracle/bin/java -Djavax.net.ssl.trustStore=/var/lib/bamboo/cacerts SSLPoke <mailserver.domain> 443
Successfully connected

 

but i still get this error when the server should be sending mails:

 

The mail settings you entered were not valid. Error thrown was: javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

 

any idea?

2 answers

1 accepted

1 vote
Answer accepted

Ok, 

i've figured it out, there was a different certificate for the Port 25 then Port 443. So adding this to the truststore did the trick.

Additionally i needed an receiving connector (the server being exchange), because bamboo didn't seem to support ntlm auth.

 

Thanks for your feedback!

I'm glad you could find out the solution yourself =]

Thank you for coming back to share it with others.
See you in the next thread!

0 votes

Hello @max

  • Can you confirm this configuration is failing for Bamboo?
  • If yes, can you try using the JNDI configuration as configured for Google in this document: Configuring Bamboo to send SMTP Email.

Some mail servers have their own specifications that may cause this configuration to be tricky.

If you want to double check your configuration prior to follow my suggestion, please make sure that Bamboo is using the exact same Java implementation and trust store. It might be the case that other Java implementation is being used therefore causing this issue.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events