No bean named 'deploymentProjectService' is defined

Getting dependency injection errors when I deploy to our Bamboo instance version 5.6.2. 

Note that when I run using atlas-run with Bamboo version 5.6.0 everything works perfectly. 

Source code is available at:

Note that I have component-imports for all dependencies -- I've tried both inside and outside the task defintion. 

I've also tried using ComponentAccessor as well as plain old constructor dependency injection for all 3 deps. 


0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,493 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you