Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,764
Community Members
 
Community Events
176
Community Groups

Has anyone had luck setting up MySQL using an external server and using a SSL connection?

We are using an RDS instance running MySQL 5.7.30 but when setting up Bamboo on the database step get the error:

Tue Jul 28 12:36:25 UTC 2020 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.

 

 

When we useSSL=false, we get an error in the interface but no error messages in the catalina log

1 answer

Hey Brandon,

 

You need to add "useSSL=false&" this parameters in the dbconfig file.

Example: <url>jdbc:mysql://localhost:3003/jiradatabase?useUnicode=true&amp;"---ADD HERE---"characterEncoding=UTF8&amp;sessionVariables=default_storage_engine=InnoDB</url>

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events