Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,599
Community Members
 
Community Events
176
Community Groups

Installed Bamboo as service but the service won't start

Bamboo was installed via zip file not an installer.   Set up the JAVA_HOME variable and the BAMBOO_HOME variable.    Then at command prompt ran InstallAsService.bat.

The script completed successfully and claims the service was installed.    In services, Bamboo appears correctly.

If I attempt to start the service, I get an error and it fails to start.

Also tried using StartBamboo.bat at the command line.   Then I get NET HELPMSG 3547.

I've tried looking in log files but don't see anything useful.

If I run start-bamboo.bat from the bin directory, Bamboo starts up just fine.   It just doesn't execute as a service for me.

1 answer

0 votes

Hello @John Toth. Welcome to Atlassian Community!

When Bamboo is configured to run as a service, it defaults to the "Local service" account. To run it successfully you need to allow that account full privileges to the whole <bamboo-home> and <bamboo-install> folders (recursively).

It is recommended to change that setting and run Bamboo as a Local user instead. Please follow this KB article for instructions:

 

Regards,

Eduardo Alvarenga
Atlassian Support APAC

Eduardo,

I gave Local Service account full privileges to bamboo home directory and also the install folder in their entirety.    Bamboo still won't start as a service.

Digging a little further, I finally found a common-daemons.log file that contained an error.   It claims it is finding the JVM however I am getting

%1 is not a valid Win32 app

We have an OpenJDK 11.0.11.9 (64bit) installed.   Which works just fine if starting Bamboo using the batch file.    It doesn't work it starting as a service.

 

John

Hello @John Toth

Make sure that you have used the 64-bit installer for Bamboo. And that the OpenJDK 11 is the only JDK you have on your system.

Otherwise, I recommend you reach out to Atlassian Support and open a ticket so we can assist you with more details.

 

Regards,

Eduardo Alvarenga 
Atlassian Support APAC

There is only one JDK installed.   And I'm pretty certain we did the 64bit installer for Bamboo (but I will double check).

Let me get clarity on something though.

Are you saying that Bamboo (even if the 32bit one) would start just fine using the start-bamboo.bat file with a 64bit JDK, but that it wouldn't start correctly when bamboo is installed as a service using InstallAsService.bat?    Because that is our apparent problem.

I would have thought Bamboo wouldn't launch in either case if there was a mismatch.

 

John

Your JDK must match the Bamboo architecture. So if you have installed Bamboo 32-bit, your JDK should follow, same for 64-bit.

That's because of the Tomcat service runner (tomcatw.exe/bamboow.exe), and not Bamboo.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events