Installation of bamboo

I am trying to istall bamboo.

I already edit the "bamboo-init.properties" file

then start the bamboo server.

after start the server i am getting following error.

HTTP ERROR: 404

Problem accessing /. Reason:

    Not Found


<small>Powered by Jetty://</small>

plz help

5 answers

1 accepted

0 vote

Hi Biswajit,

Would you confirm if the Java JDK being pointed by the local JAVA_HOME environment variable is a Sun/Oracle JDK? You can check the current Java vendor running "java -version" on the console.

Bamboo currently supports Oracle JDK and OpenJDK. Please, make sure that the JAVA_HOME variable is pointing to one of these.

Let us know what you find,

Cheers,

Renan

plz help me ...its urgent

0 vote

What url are you trying to access?

anyone aware of this problem plz help

0 vote

Hi,

Indeed, to edit the bamboo-init.properties file is the only necessary step before running Bamboo.

The 404 HTTP error can mean that a resource needed by the server may not be available, causing the server to be unavailable.

Would you attach your bamboo-init.properties file here as well as the server log file so we can check what is being reported?

Cheers,

Renan

2012-06-20 20:13:36.599:WARN::FAILED WebAppContext@954f00@954f00/,file:/home/office/Desktop/ebook/Bamboo/webapp/,webapp: java.lang.Error: org.xml.sax.SAXNotSupportedException: http://apache.org/xml/features/nonvalidating/load-external-dtd
2012-06-20 20:13:36.601:WARN::Error starting handlers
java.lang.Error: org.xml.sax.SAXNotSupportedException: http://apache.org/xml/features/nonvalidating/load-external-dtd
	at org.eclipse.jetty.xml.XmlParser.setValidating(XmlParser.java:115)
	at org.eclipse.jetty.xml.XmlParser.&lt;init&gt;(XmlParser.java:73)
	at org.eclipse.jetty.webapp.WebDescriptor.newParser(WebDescriptor.java:64)
	at org.eclipse.jetty.webapp.WebDescriptor.ensureParser(WebDescriptor.java:55)
	at org.eclipse.jetty.webapp.Descriptor.parse(Descriptor.java:54)
	at org.eclipse.jetty.webapp.WebDescriptor.parse(WebDescriptor.java:142)
	at org.eclipse.jetty.webapp.MetaData.setDefaults(MetaData.java:116)
	at org.eclipse.jetty.webapp.WebXmlConfiguration.preConfigure(WebXmlConfiguration.java:46)
	at org.eclipse.jetty.webapp.WebAppContext.preConfigure(WebAppContext.java:463)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:491)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
	at org.eclipse.jetty.server.Server.doStart(Server.java:243)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at com.atlassian.bamboo.server.Server.main(Server.java:75)
2012-06-20 20:13:36.633:INFO::Started SelectChannelConnector@0.0.0.0:8085
****************************************************************
*                                                              *
* You can see Bamboo by visiting http://localhost:8085/
*                                                              *
********************

I chacked the log file it shows

Starting Bamboo using Java 1.5.0 from Free Software Foundation, Inc.
Port        = 8085
Web App     = webapp
contextPath = /
2012-06-20 20:13:35.375:INFO::jetty-7.2.1.v20101111
2012-06-20 20:13:36.578:WARN::EXCEPTION 
org.xml.sax.SAXNotSupportedException: http://apache.org/xml/features/nonvalidating/load-external-dtd
	at gnu.xml.stream.SAXParser.setProperty(libgcj.so.11)
	at gnu.xml.stream.SAXParser.setFeature(libgcj.so.11)
	at org.eclipse.jetty.xml.XmlParser.setValidating(XmlParser.java:108)
	at org.eclipse.jetty.xml.XmlParser.&lt;init&gt;(XmlParser.java:73)
	at org.eclipse.jetty.webapp.WebDescriptor.newParser(WebDescriptor.java:64)
	at org.eclipse.jetty.webapp.WebDescriptor.ensureParser(WebDescriptor.java:55)
	at org.eclipse.jetty.webapp.Descriptor.parse(Descriptor.java:54)
	at org.eclipse.jetty.webapp.WebDescriptor.parse(WebDescriptor.java:142)
	at org.eclipse.jetty.webapp.MetaData.setDefaults(MetaData.java:116)
	at org.eclipse.jetty.webapp.WebXmlConfiguration.preConfigure(WebXmlConfiguration.java:46)
	at org.eclipse.jetty.webapp.WebAppContext.preConfigure(WebAppContext.java:463)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:491)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
	at org.eclipse.jetty.server.Server.doStart(Server.java:243)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at com.atlassian.bamboo.server.Server.main(Server.java:75)

0 vote

Hi,

I can see that Bamboo can see a JAVA JDK 1.5 (version not supported) as being the one available:

Starting Bamboo using Java 1.5.0 from Free Software Foundation, Inc.

Please, make sure that version 1.6 or 1.7 are the ones available to in the JAVA_HOME variable.

You can see more details about the supported versions in this page.

Cheers,

Renan

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,093 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot