I upgraded Bamboo, deleted a plan, recreated the plan, but the old build logs are getting in the way

I just upgraded from Bamboo 3.1.4 to 3.2, and it wasn't entirely smooth. But I got everything back up and running, agents re-added with the new jar file and all that.

For one of our builds I decided to redo from scratch since it didn't work that well and we aren't that far into it. I deleted the plan in Bamboo but when I recreated it using the same project key and build key I see the old build number in the status area of Bamboo.

How can I either clear all the history of the previous build or fix it so that I just continue from that number? In either case Bamboo just hangs there now and won't build.

I've already done a complete re-index of Bamboo and restarted it several times as well as creating and re-deleting that project several times already.

2 answers

1 accepted

Accepted Answer
0 votes

The deletion process is not immediate, can you check the log files that it has indeed started/finished and then recreate the plan?

That seems to be part of the problem, it's not deleting the build from the SQL DB it looks like. I'll have to figure out what I did during the upgrade.

0 votes

Or maybe it's this bug

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

436 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you