Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,338
Community Members
 
Community Events
176
Community Groups

I am getting below message when I am about to start Bamboo?

"C:\Program Files\Bamboo\bin\start-bamboo.bat"

To run Bamboo in the foreground, start the server with start-bamboo.bat /fg
The CATALINA_HOME environment variable is not defined correctly
This environment variable is needed to run this program

2 answers

0 votes

Check you have set the home path correctly

 

From the install guide

Set up your Bamboo home directory — this is the directory where Bamboo will store its root configuration data. To do this, edit the file named bamboo-init.properties in the <Bamboo installation directory>/atlassian-bamboo/WEB-INF/classes/ directory. In this file, insert the property "bamboo.home", with an absolute path to your Bamboo home directory. Your file should look something like this:

bamboo.home=C:/test/bamboo-home

Hi Steve, Acttually the thing is my bamboo-home folder is empty. No files are present in the folder bamboo-home. Is there anything to be present in this folder after the installation.

That's fine, you are pointed the server to that directory to store files created during the next steps.

Still the same problem exists. What can I do?

Jeyanthan I Atlassian Team Mar 08, 2018

I suggest you reinstall Bamboo and make sure you run Bamboo as a Windows service as the local user as explained in this post.

0 votes
Mirek Community Leader Mar 06, 2018

Please check all paths and environment variables if are correct. This documentation might help to show where you should look - https://confluence.atlassian.com/bamboo/configuring-your-system-properties-289277345.html

I suppose that wrong path is used. By default (if you did not change it) it might be C:\Program Files\Bamboo ..

Hi Mirek I have checked everything and is correct. But still also I am getting the same error. At the start it showed some error related to jdk and jre. I have changed the pwd from Bamboo bin to jdk bin(Even though it is specified in Environment Variables). starting the Bamboo by specifying with complete path. Please can you give me some suggestion.

Mirek Community Leader Mar 06, 2018

You are getting this error, right?

The CATALINA_HOME environment variable is not defined correctly
This environment variable is needed to run this program

Are you sure that there is correct path to catalina set by enviroment variable CATALINA_HOME? BTW - Good version of Java is used? What you get if you print CATALINA_HOME variable?

Hi Mirek,

C:\>set JAVA_HOME="C:\Program Files\Java\jdk1.8.0_161\bin"

C:\>set CATALINA_HOME=C:\Bamboo\bin

C:\>set PATH=%PATH%;%JAVA_HOME%\bin;%CATALINA_HOME%\bin

C:\>set CATALINA_HOME=C:\Bamboo\lib

C:\>

Even after setting the paths also I am getting the same error.

C:\Program Files\Java\jdk1.8.0_161\bin>"C:\Bamboo\bin\start-bamboo.bat" /fg
The CATALINA_HOME environment variable is not defined correctly
This environment variable is needed to run this program

 

 

This is the error I am getting

Mirek Community Leader Mar 07, 2018

is C:\Bamboo your <Bamboo Install> directory? If not please try to set up CATALINA_HOME using it ..

BTW - but first please remember also to have a semicolon on the end of environment variables

not..

PATH=%PATH%;%JAVA_HOME%\bin;%CATALINA_HOME%\bin

but..

PATH=%PATH%;%JAVA_HOME%\bin;%CATALINA_HOME%\bin;

Those are details but sometimes count :)

Thanks for your reply. I have done what you mentioned in your previous post but still the problem exists. I think some problem from my system.

C:\Bamboo\bin>start-bamboo.bat /fg
'#' is not recognized as an internal or external command,
operable program or batch file.
'#' is not recognized as an internal or external command,
operable program or batch file.
'#set' is not recognized as an internal or external command,
operable program or batch file.
'#' is not recognized as an internal or external command,
operable program or batch file.

Bamboo Server Edition
Version : 6.4.0

The system cannot find the path specified.

If you encounter issues starting or stopping Bamboo Server, please see the Troubleshooting guide at https://confluence.atlassian.com/display/BAMBOO/Installing+Bamboo+on+Windows

Files\Java\jre1.8.0_161\bin"" was unexpected at this time.

 

Is there any solution for this.

Mirek Community Leader Mar 08, 2018

You configuration files seems to be messed up .. Maybe you did some typos or additional special characters. Please check syntax.

I had similar problem and it was fixed setting env variabl for CATALINE_HOME as Mirek described `%CATALINA_HOME%\bin;` while CATALINA_HOME itself pointed on installation directory, as Mirek also wrote.

Like Mirek likes this
Mirek Community Leader Jun 29, 2021

Thanks @Závodný Petr . Glad that it helped

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events