Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,962
Community Members
 
Community Events
168
Community Groups

Cannot seem to register Bamboo license when installing Bamboo datacenter

Hello, I'm trying to install and configure Bamboo Datacenter v1.2.4 onto a CentOS 7 VM but I cannot get past the license page. I've tried running against both OpenJDK 8 and 11 but get the same issue. After a successful install, I'm asked to enter my license key. When I enter that key, I'm getting a message back telling me that I'm using an invalid key. I've created a trial license on my account using the provided server ID and double checked that the server ID matches and everything looks correct.

When evaluating the logs, I can see a bunch of invalid character errors with a bunch of stacktrace output but nothing that makes any sense. It's like it cannot parse the data being entered into the webform. I've also tried adding the license directly to bamboo.cfg.xml and bump the installer along one step but after completing the rest of the install and restarting, I'm brought back to the license entry page.

Here's a dpaste link with the stacktrace data included

https://dpaste.org/ByuK

1 answer

Turns out I was installing a very old version of Bamboo. Not sure how I managed to get things mixed up. I just assumed that Bamboo Datacenter was using a different versioning number than server. I was wrong and I was actually installing v1.2.4 (facepalm).

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events