Build Times for Bamboo 5

Hi

I'm interested in news regarding the Build Times plugin for Bamboo

Released version is only for Bamboo 4.x, but this plugin would be very usefull for Bamboo 5 as well!

Latest version was released a year ago, and hasn't been updated since.

Perhaps someone from the Bamboo team can answer this?

https://marketplace.atlassian.com/plugins/com.atlassian.bamboo.plugin%3Abamboo-build-times-plugin

Background

I found this article interesting and wanted to try the plugin

http://blogs.atlassian.com/2012/07/how-many-bamboo-build-agents/

quote:

Build Times was built by Atlassian Labs and we use it on our internal Bamboo servers, so you can rest assured that it will be well-maintained.

end quote:

3 answers

1 accepted

atlas-package is apparently the magic trick!

Managed to package and install plugin now.

thanks for SDK tip!

No worries.

Whenever I encounter a compile issue with an Atlassian plugin its normally an out of date SDK or the SDK is in need of re-install.

0 vote
Timothy Chin Community Champion Feb 17, 2014

If you have Mercurial, you should clone the code and compile it yourself against a higher version of Bamboo and test it.

Nice tip, and I downloaded mercurial and tried it.

However, it fails with the following error:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.0-alpha-4:enforce (enforce-build-environment) on project bamboo-build-times-plugin: Execution enforce-build-environment of goal org.apache.maven.plugins:maven-enforcer-plugin:1.0-alpha-4:enforce failed. NullPointerException -> [Help 1]

Tried to build both the latest tag and the default branch

It this actually works on Bamboo, it would be easier if Atalassian could just release it.

Try Maven 2 instead of 3.

Atlassian SDK 5 dropped Maven 2, but you can still get the older version:

brew install atlassian-plugin-sdk4

Do you have the latest Atlassian SDK installed?

I built the plugin some time ago for Bamboo 4.5 and have since upgraded to 5.3 and it still works.

I have installed the latest Atlassian SDK through Homebrew (osx).

Simply running mvn clean install gives me the same error.

So how do you build this? And how is the SDK going to help me?

There is no relevant information on bitbucket/checked out code on how to actually do this.

(other than running mvn clean install, as I normally would assume is the correct way)

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot