Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo server not able to point to a browser after installation

I installed Bamboo 5.10.3 on an AWS Linux instance and 7.1 on a CentOS 7 machine. I changed the ports from 8080 to 8085 but it will still not start nor point to a browser. I checked bamboo home, bamboo installation directories and they've all been set up properly. What should I do? We need this server to start so we can start using it.

Thank you

1 answer

0 votes
Kanwar Atlassian Team Sep 28, 2020

Hi @Efua Larbi ,

Let's verify if Bamboo is running, and on which port.

  1. What do you see when you run ps -ef | grep com.atlassian.bamboo?
    1. If the above command returns nothing, try running ./bamboo.sh console and share the output
  2. What is the output of sudo netstat -tunlp | grep 8085 ? This test will show if any java process is listening on port 8085.
  3. Finally, also check if there is any firewall that may be blocking port 8085.

Cheers.

Hi @Kanwar running the  ps -ef | grep com.atlassian.bamboo showed the process id of bamboo and that it has been started.

The sudo sudo netstat -tunlp | grep 8085 showed that java was listening on the port. However I was able to get one of my instances with the Bamboo installation (7.1 version)  running and pointing to the browser; server wizard of Bamboo. I added a rule under Security Groups to "All TCP" "Anywhere".   However my other AWS instance with 5.10 version of Bamboo is still not running. I changed the ports under conf/server.xml to 8080 but its still not working. What else am I doing wrong.

Daniel Ebers Community Leader Oct 18, 2020

If I get you right you are basically dealing with two independent Bamboo installations. Could you please describe a more precisely what the status with the Bamboo 5.10 installation is?

As far as I understoof the Bamboo 7.1 instance is running fine why we can put this aside for a moment in this consideration.

Is for the still troubling installation a process visible using "ps" and the firewall configured so that access is possible?

Cheers,
Daniel

My Bamboo is up and running now. I removed the 5.1 version and installed 6.1. I also stopped Bamboo and restarted it, also changed the port numbers in /server.xml file and it worked. If you’ve a similar problem you can also try disconnecting one of the connectors in the /server.xml file and it’ll work.

Thanks

Efua

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.2 is here!

I'm happy to announce that Bamboo 7.2 has been released and it’s overflowing with awesome new features. This will be the last major Server release before the launch of Bamboo DC. Bamboo logs We...

437 views 5 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you