Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo SCP Task not working ver 6.7.1

scp task not working. tried on 6.4.1 and upgraded this weekend to 6.7.1 and still not working.

See logs

Build Deployment of 'release-2' on 'INT' started building on agent Default Agent
21-Jan-2019 10:48:18 
21-Jan-2019 10:48:18 Build working directory is /opt/bamboo/bamboo-home/xml-data/build-dir/4489217-4554754
21-Jan-2019 10:48:18 Executing build Deployment of 'release-2' on 'INT'
21-Jan-2019 10:48:18 Starting task 'Clean working directory task' of type 'com.atlassian.bamboo.plugins.bamboo-artifact-downloader-plugin:cleanWorkingDirectoryTask'
21-Jan-2019 10:48:18 Cleaning working directory '/opt/bamboo/bamboo-home/xml-data/build-dir/4489217-4554754'
21-Jan-2019 10:48:18 Finished task 'Clean working directory task' with result: Success
21-Jan-2019 10:48:18 Starting task 'Download release contents' of type 'com.atlassian.bamboo.plugins.bamboo-artifact-downloader-plugin:artifactdownloadertask'
21-Jan-2019 10:48:18 Finished task 'Download release contents' with result: Success
21-Jan-2019 10:48:18 Starting task 'Download Artifact to working directory' of type 'com.atlassian.bamboo.plugins.bamboo-scp-plugin:scptask'
21-Jan-2019 10:48:18 Error occurred while running Task 'Download Artifact to working directory(3)' of type com.atlassian.bamboo.plugins.bamboo-scp-plugin:scptask.
21-Jan-2019 10:48:18 java.lang.NullPointerException
21-Jan-2019 10:48:18         at<init>(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.plugins.scp.ScpTask.artifactToScpFromTransferTask(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.plugins.scp.ScpTask.getPathSpecToCopy(
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at com.atlassian.bamboo.plugins.scp.ScpTask.execute(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.task.TaskExecutorImpl.lambda$executeTasks$1(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.task.TaskExecutorImpl.executeTaskWithPrePostActions(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.task.TaskExecutorImpl.executeTasks(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.task.TaskExecutorImpl.execute(
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at$waitAndPerformBuild$0(
21-Jan-2019 10:48:18         at com.atlassian.bamboo.variable.CustomVariableContextImpl.withVariableSubstitutor(
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at$
21-Jan-2019 10:48:18         at com.atlassian.bamboo.utils.BambooRunnables$
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18         at$
21-Jan-2019 10:48:18         at
21-Jan-2019 10:48:18 Finalising the build...
21-Jan-2019 10:48:18 Stopping timer.
21-Jan-2019 10:48:18 Build 4489217-4554754-5668874 completed.
21-Jan-2019 10:48:18 Finished processing deployment result Deployment of 'release-2' on 'INT'




1 answer

0 votes
Gonchik Tsymzhitov
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Feb 09, 2019



Looks like the problem related the shared artifact. 

Have you check it? 

And are you planning update Bamboo to 6.8.0 release? :)



Gonchik Tsymzhitov

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events