Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,810
Community Members
 
Community Events
176
Community Groups

Hi, 

I gave bamboo.home directory as

<path>/bamboo-home

which is totally different then Bamboo Installation as below

<path>/atlassian-bamboo-6.8.1

However when I started Bamboo server (using sudo su)

It created a directory inside installation path like this with a special character folder also getting created

<path>/atlassian-bamboo-6.8.1/‎⁨/<path>/bamboo-home

 

I am following this documentation

https://confluence.atlassian.com/bamboo0607/installing-bamboo-on-mac-os-x-966044823.html

Can someone help me with this please?

Why it is creating folder inside installation directory?

Thanks, 

Somendu

2 answers

The special character looks like it is a UTF-8 "BOM" (U+FEFF). Some editors including Notepad insert this character in text files when saving as UTF-8. Since this BOM is a zero-width space character, it's an invisible marker.

 

Solution: save as plan ASCII.

0 votes

Hi @Somendu Maiti

Difficult to know what exactly is happening there, but lets double check the Bamboo home configuration.

The file to configure it is located at:

<path>/atlassian-bamboo-6.8.1/atlassian-bamboo/WEB-INF/classes/bamboo-init.properties

The line should be like:

bamboo.home=/<path>/bamboo-home

Please make sure you have an absolute path here. It should start with "/" and the folder bamboo-home does not need to exist.

Another observation is that you should not use sudo su to run the Bamboo process. The best option is to make sure the user running it is the owner of both Bamboo install and Bamboo home folders.

 

Suggestion for moving forward

  1. Stop Bamboo process.
  2. Remove the strange folder created from your installation directory.
    ⚠️ I'm assuming you can lose the data in there since this is a new install.
  3. Make sure the user starting the Bamboo process is the owner of all installation files and it has permissions to edit the location where the bamboo-home will be created. You can use the command chown for this.
  4. Edit the Bamboo home path in bamboo-init.properties. Make sure this file has the Bamboo home absolute path with a "/" at the beginning and use quotes if the path has spaces.  
  5. Start the process again.

If that does not solve the issue we will probably need to dig into your server logs.

Hello Daniel, 

Glad to hear from you. The problem got resolved automatically. 

I deleted Atlassian setup. 

Downloaded new and done all process, and bamboo-home folder got created properly. 

Hope it works fine moving forward :)

 

Thanks,

Somendu

Like Daniel Santos likes this

I'm glad that you are moving forward.
If you have new questions don't hesitate to come back to our community =]

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events