Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

[Bamboo] Git credentials storage exception.

Andrzej Szewczyk November 30, 2018

I am trying to set up my CI server based on Bamboo, however I am not able to link any repository to Bamboo. Every time I add a repository URL (I tested all Valid URLs configurations listed here: link) I do receive Git credentials storage exception once I press the Test connection button.

I found many similar topic, but all of them has not been answered yet.

I did a lot of testing and investigation. I tried various configuration of git credentials manager, but none of them has worked. My default git credentials configuration is as follows:

1) git config --local credential.helper manager

2) git config --global credential.helper store

 I also modified/removed credentials in Control Panel > All Control Panel Items > Credential Manager and I ended up with no success.

The issue exists on the company PC as well as it does exist on my private PC.

Below is a snippet from the atlassian-bamboo.log file that contains information about the error:

2018-11-30 15:44:19,266 INFO [http-nio-8085-exec-4] [RepositoryResource] Testing connection to repository (type: Git, location: C:/Projects/Bamboo_CI/git_testing)
2018-11-30 15:44:19,418 INFO [http-nio-8085-exec-4] [RepositoryResource] Failed to connect to repository (type: Git, location: C:/Projects/Bamboo_CI/git_testing, time: 151.2 ms, errors: [Git credentials storage exception.])
2018-11-30 15:44:19,986 INFO [http-nio-8085-exec-6] [AccessLogFilter] w19220 POST http://localhost:8085/rest/analytics/1.0/publish/bulk 393536kb
2018-11-30 15:44:23,759 INFO [18-BAM::Default Agent::Agent:pool-32-thread-1] [BuildAgentControllerImpl] Agent 360449 checking build queue for executables...
2018-11-30 15:44:24,830 INFO [9-BAM::PlanExec:pool-15-thread-3] [DefaultErrorHandler] Recording an error: Unable to detect changes : TEST-TEST : : Git credentials storage exception.

3 answers

0 votes
Intakhab Sheikh September 4, 2020

I am trying to connect with GITHUB  repo, it is saying "Git credentials storage exception.". Please let me know why this is not connecting.? any help would be appreciated 

Juan Manuel Zuñiga October 8, 2020

Happened to me using Bamboo on Windows. Fixed by adding explicit permissions to the process owner and by cleaning the bamboo temp directory.

Like Keidi Gjika likes this
Yang Li December 28, 2020

Hi Juan,

would it be possible for you to share how to add explicit permissions to the process owner and clean the bamboo temp directory?

Juan Manuel Zuñiga November 30, 2021

Me from the future. I'm apologizing for being unpolite. Somehow, I never saw the reply. 

Using Windows Folder permissions dialogue to grant "admin" rights for the user running the bamboo process worked.

0 votes
Rajkumar July 31, 2020

I also facing same issue even repositories connecting to git hub and bitbucket cloud.

Any specific configuration do we have to do in Bamboo. I am using bamboo 7.0.4.

0 votes
Rafael Pinto Sperafico
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 28, 2018

HI @Andrzej Szewczyk,

Could you please let us know:

It is important to notice that there are some stets to be taken to configure SmartGit correctly. Therefore, you if you are looking for a simpler solution, Git for Windows seems appropriated.

  • It is important to identify the type of authentication you are using based on repository's URL, for instance, if you are making use of SSH (git@bitbucket.org:USERNAME/repositorySlug.git), then you should be looking at SSH keypair authentication.
    Now, if you are connecting to a repository that uses HTTP(S), file:///, other than SSH, then you should be authenticating using username/password

Based on log entries provided, it seems you are connecting to a Git repository that is located in a given directory (e.g. C:/Projects/Bamboo_CI/git_testing). Have you attempted on cloning this repository from the same box where Bamboo is running by simply opening up Command Prompt (cmd.exe) or any Git client, other than Bamboo?

Once the above is working, then you could move to Bamboo and set up the Git repository. Please, remember that you should be Defining a new version control capability in Bamboo.

Alternatively, you could attempt on creating a Git repository on https://bitbucket.org/ and run repository configuration(s) in Bamboo.

Kind regards,

Rafael

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events