Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,132
Community Members
 
Community Events
176
Community Groups

Bamboo 6.3.0 won't start

Hello,

We are using Bamboo 6.3.0 on Windows 2012. Everything was working fine with this install until recently when the service failed to start on a system reboot. Nothing with the Bamboo or Java configuration has changed.

The Bamboo log looks normal until it gets to the system information box, at which point it records the warning below:

2019-01-15 19:38:52,075 ERROR [setupDefaultGeneralBackgroundThread] [XmlWebApplicationContext] Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'systemInfoFactory' defined in class path

 

After throwing this warning the service begins shutting down. We've double checked the ownership and confirmed that the system account running the Bamboo service has full read/write access to the Bamboo home directory. What else should we check to resolve this?

1 answer

1 accepted

1 vote
Answer accepted

Hi @DPool,

We have very few cases with a similar error and they were related to a misleading configuration file (that could be either missing or corrupted).

Do you mind checking if the file <Bamboo_Home>\xml-data\configuration\administration.xml is there and if it has content inside?

This would be default content for a Bamboo 6.7.2 instance:

<AdministrationConfiguration>
<myBaseUrl>http://myBambooUrl</myBaseUrl>
<myUseGzipCompression>true</myUseGzipCompression>
<myInstanceName>Atlassian Bamboo</myInstanceName>
<deploymentExpiryEnabled>true</deploymentExpiryEnabled>
<myBuildExpiryConfiguration>
<myDuration>0</myDuration>
<buildsToKeep>0</buildsToKeep>
<maxIgnoredLogSize>-1</maxIgnoredLogSize>
<expiryTypeNothing>false</expiryTypeNothing>
<expiryTypeResult>false</expiryTypeResult>
<expiryTypeArtifact>false</expiryTypeArtifact>
<expiryTypeBuildLog>false</expiryTypeBuildLog>
<enabled>false</enabled>
</myBuildExpiryConfiguration>
<myBuildHangingConfig>
<multiplier>2.5</multiplier>
<minutesBetweenLogs>20</minutesBetweenLogs>
<minutesBeforeQueueTimeout>5</minutesBeforeQueueTimeout>
<disabled>false</disabled>
</myBuildHangingConfig>
<concurrentBuildConfig>
<enabled>false</enabled>
<numberConcurrentBuilds>1</numberConcurrentBuilds>
</concurrentBuildConfig>
<storageLimits>
<softLimit>20</softLimit>
<hardLimit>25</hardLimit>
</storageLimits>
<dashboardPageSize>50</dashboardPageSize>
<enableSignup>true</enableSignup>
<enableAnonymousAccess>true</enableAnonymousAccess>
<enableViewContactDetails>false</enableViewContactDetails>
<enableRestrictedAdmin>false</enableRestrictedAdmin>
<soxComplianceModeEnabled>false</soxComplianceModeEnabled>
<remoteAgentFunctionEnabled>true</remoteAgentFunctionEnabled>
<remoteAgentAuthenticationEnabled>true</remoteAgentAuthenticationEnabled>
<auditLoggingEnabled>true</auditLoggingEnabled>
<gravatarSupportEnabled>true</gravatarSupportEnabled>
<gravatarServerUrl>https://secure.gravatar.com/avatar/</gravatarServerUrl>
<showAdminContactDetailsToAnonymousUsers>false</showAdminContactDetailsToAnonymousUsers>
<unauthenticatedRemoteTriggerAllowed>false</unauthenticatedRemoteTriggerAllowed>
<systemProperties/>
<buildHangedInQueueNotificationTimeout>120</buildHangedInQueueNotificationTimeout>
<branchDetectionCheckInterval>300</branchDetectionCheckInterval>
<xsrfProtectionEnabled>true</xsrfProtectionEnabled>
<xsrfAllowsMutativeGets>false</xsrfAllowsMutativeGets>
<serializationSecurityConfig>
<bandanaMethod>STRICT_BLACKLIST</bandanaMethod>
<xStreamMethod>WHITELIST</xStreamMethod>
</serializationSecurityConfig>
<securityTokenRequiredFromAgents>false</securityTokenRequiredFromAgents>
<manageAcceptedSshHostKeys>false</manageAcceptedSshHostKeys>
<rssSecurityConfiguration>
<enabled>true</enabled>
<executeSpecsInDocker>true</executeSpecsInDocker>
<dockerImage>atlassian/bamboo-specs-runner:6.7.2</dockerImage>
</rssSecurityConfiguration>
</AdministrationConfiguration>

(!) Please make sure you don't add any sensitive information from your instance in community threads.

Hi Daniel,

 

That folder had two files, "administration" which is 0KB and "administration - copy" that is 6KB. I backed up the two files, and renamed the original to .old and then renamed the copy to just administration. The XML file looks correct.

 

I started the service, but the Bamboo site is still unavailable. Unlike previously, the service does at least stay running. What would you suggest we check next?

Do you see any new error in the logs?
Have you tried to access the instance though its direct IP to avoid any proxy issue?

Bingo! We found another configuration file with bad data that was loading. It looks like removing that has solved our issue. This can be considered resolved.

 

Thank you very much for the help!

Like Daniel Santos likes this

You are welcome mostly @DPool!

Jimmy Seddon Community Leader Jun 21, 2019

Thanks again @Daniel Santos!

I was running into issues settup up a test server and this helped me resolve those issues.

Like Daniel Santos likes this

I'm glad it helped! Thank you @Jimmy Seddon for taking the time to share your feedback here. =]

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events