I'm trying to use an Oracle image from the Docker Hub Store (where there is an active subscription). The image is being used as a service in BB Pipelines.
Performing docker login locally and pulling the image works just fine, however, on BB Pipelines it's not working.
I followed this article and have the following in my bitbucket-pipelines.yml:
definitions:
services:
db-oracle:
image: store/oracle/database-enterprise:12.2.0.1-slim
username: $DOCKER_HUB_USERNAME
password: $DOCKER_HUB_PASSWORD
email: $DOCKER_HUB_EMAIL
The variables referenced are setup on the repository, but Pipelines still fails with:
rpc error: code = Unknown desc = Error response from daemon: pull access denied for store/oracle/database-enterprise, repository does not exist or may require 'docker login'
Thanks in advance for any help!