Hello,
we have some major crash/problem as it seems the database disappeared or something related to it crashed very badly in a permanent manner. The usual "quick fixes" (restart JIRA service, restart host PC, etc.) did not help.
I need a *quick* solution, as our whole team relies on JIRA for running their projects.
We do have daily backups of everything, the entire /JIRA_AppData directory as well as daily .zip file containing entities.xml (around 18 MB) and activeobjects.xml (1.6 MB).
Please provide me either with
- a way how to restore the backed up database to the non-functioning JIRA (as Tomcat just always gives the error message "HTTP Status 500 - Could not determine database type. (User not found: SA)", and I cannot login anywhere anymore)
- or the advice to use the "opportunity" to just wipe our entire JIRA installation clean, download the latest JIRA, and install from scratch and load the backed up database with the /JIRA_AppData from the old installation (if this works smoothly!!!)
According to the logfiles all of this occured in the early morning hours two days ago on the 17th Oct, when the daily backup-script-run shuts down JIRA, performs the backup, and activates JIRA again:
localhost.2018-10-16.log (320 B filesize)
********************************************************************************
Okt 16, 2018 5:03:33 AM org.apache.catalina.core.ApplicationContext log
INFORMATION: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: destroy called
Okt 16, 2018 5:07:22 AM org.apache.catalina.core.ApplicationContext log
INFORMATION: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: loaded (conf ok)
jira230914150550-stdout.2018-10-16.log (248 kB filesize)
********************************************************************************
localhost.2018-10-17.log (84 MB filesize due to the errors)
********************************************************************************
Okt 17, 2018 5:03:35 AM org.apache.catalina.core.ApplicationContext log
INFORMATION: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: destroy called
Okt 17, 2018 5:06:59 AM org.apache.catalina.core.ApplicationContext log
INFORMATION: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: loaded (conf ok)
Okt 17, 2018 5:06:59 AM org.apache.catalina.core.StandardWrapperValve invoke
SCHWERWIEGEND: Servlet.service() for servlet [servlet-module-container-servlet] in context with path [] threw exception
org.ofbiz.core.util.GeneralRuntimeException: Could not determine database type. (User not found: SA)
at org.ofbiz.core.entity.config.DatasourceInfo.getDatabaseTypeFromJDBCConnection(DatasourceInfo.java:409)
at org.ofbiz.core.entity.GenericDAO.selectListIteratorByCondition(GenericDAO.java:826)
at org.ofbiz.core.entity.GenericDAO.selectByAnd(GenericDAO.java:725)
at org.ofbiz.core.entity.GenericHelperDAO.findByAnd(GenericHelperDAO.java:150)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:901)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:879)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:848)
...
...
...
jira230914150550-stdout.2018-10-17.log (413 MB (!!) filesize due to the errors)
********************************************************************************
Also the /JIRA_AppData/database/ folder now contains no database, but only 4 small files:
- jiradb.lck (16 B filesize)
- jiradb.log (empty)
- jiradb.properties (429 B filesize)
- jiradb.script (60 B filesize)
Normally there were always 2 files, the same jiradb.properties file, and a 17 MB large jiradb.script file.
THANKS a lot for help....