The memory in the VM (where Jira was installed) has been full due to which Jira failed to start up. I cleared the logs and started the Jira instance using ./start-jira.sh and getting the below error. There has been no change in the configuration settings. Jira Version 7.3.1
2018-03-05 17:15:57,455 JIRA-Bootstrap INFO [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from /root/JIRA/home/dbconfig.xml
2018-03-05 17:16:03,732 JIRA-Bootstrap ERROR [c.a.config.bootstrap.DefaultAtlassianBootstrapManager] Could not successfully test your database:
org.h2.jdbc.JdbcSQLException: General error: "java.lang.IllegalStateException: The transaction log might be corrupt for key 124472 [1.4.185/100]" [50000-185]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:345)
at org.h2.message.DbException.get(DbException.java:168)
at org.h2.message.DbException.convert(DbException.java:295)
at org.h2.engine.Database.openDatabase(Database.java:297)
at org.h2.engine.Database.<init>(Database.java:260)
at org.h2.engine.Engine.openSession(Engine.java:60)
at org.h2.engine.Engine.openSession(Engine.java:167)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:145)
at org.h2.engine.Engine.createSession(Engine.java:128)
at org.h2.engine.Engine.createSession(Engine.java:26)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:347)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:108)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:92)
at org.h2.Driver.connect(Driver.java:72)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.atlassian.config.bootstrap.DefaultAtlassianBootstrapManager.getTestDatabaseConnection(DefaultAtlassianBootstrapManager.java:347)
at com.atlassian.jira.config.database.JdbcDatasource.getConnection(JdbcDatasource.java:211)
Caused by: java.lang.IllegalStateException: The transaction log might be corrupt for key 124472 [1.4.185/100]
at org.h2.mvstore.DataUtils.newIllegalStateException(DataUtils.java:773)
at org.h2.mvstore.db.TransactionStore$TransactionMap.getValue(TransactionStore.java:1224)
at org.h2.mvstore.db.TransactionStore$TransactionMap.getValue(TransactionStore.java:1184)
at org.h2.mvstore.db.TransactionStore$TransactionMap.get(TransactionStore.java:1161)
at org.h2.mvstore.db.TransactionStore$TransactionMap.get(TransactionStore.java:1129)
at org.h2.mvstore.db.MVPrimaryIndex.<init>(MVPrimaryIndex.java:79)
at org.h2.mvstore.db.MVTable.init(MVTable.java:90)
at org.h2.mvstore.db.MVTableEngine.createTable(MVTableEngine.java:130)
at org.h2.mvstore.db.MVTableEngine.createTable(MVTableEngine.java:41)
at org.h2.schema.Schema.createTable(Schema.java:582)
at org.h2.command.ddl.CreateTable.update(CreateTable.java:137)
at org.h2.engine.MetaRecord.execute(MetaRecord.java:58)
at org.h2.engine.Database.open(Database.java:732)
at org.h2.engine.Database.openDatabase(Database.java:266)
... 41 more
2018-03-05 17:16:03,749 JIRA-Bootstrap ERROR [c.a.jira.health.HealthChecks] JIRA couldn't connect to your database
2018-03-05 17:16:03,749 JIRA-Bootstrap ERROR [c.a.jira.health.HealthChecks] JIRA failed to establish a connection to your database.
This could be because:
- Your database isn't running
- The configuration of your dbconfig.xml file is incorrect (user, password, or database URL etc.)
- There is a network issue between JIRA and your database (e.g. firewall, database doesn't allow remote access etc.)
There are several other solutions you can try, review our documentation and see what works for you.
2018-03-05 17:16:03,753 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running JIRA startup checks.
2018-03-05 17:16:03,753 JIRA-Bootstrap FATAL [c.a.jira.startup.JiraStartupLogger] Startup check failed. JIRA will be locked.
2018-03-05 17:16:03,972 JIRA-Bootstrap INFO [c.a.jira.startup.LauncherContextListener] Memory Usage:
---------------------------------------------------------------------------------
Heap memory : Used: 221 MiB. Committed: 489 MiB. Max: 745 MiB
Non-heap memory : Used: 49 MiB. Committed: 50 MiB. Max: 1264 MiB
---------------------------------------------------------------------------------
TOTAL : Used: 270 MiB. Committed: 539 MiB. Max: 2009 MiB
---------------------------------------------------------------------------------