Hello,
Our Jira database is on MSSQL server. Jira was upgraded and now there are errors about unsupported collation. There is no easy way to change collation of MSSQL database. Copy database wizard from MSSQL doesn't change collation. Do you have any suggestions on how to solve unsupported collation issue with MSSQL?
Hi Joe,
Rather than trying to change your existing database, I have found it much easier to simply create a new database with the correct collation, and then import an XML backup that Jira creates of your data. This way you can correct that collation error.
Please follow these steps to correct this problem:
By following these steps you can then import your previous data into a supported database with the correct database setup.
Joe,
Had the same issue. We just scheduled a maintenance outage, shut down JIRA, made snapshots and changed the collation. you can see how to do it here: https://docs.microsoft.com/en-us/sql/relational-databases/collations/set-or-change-the-database-collation#TsqlProcedure
When we brought everything back up everything was good. We did it in out test environment first.
It looks like you're new here. Sign in or register to get started.