We are attempting to upgrade from Jira 6.4.8 to 7.7.
(We were using a SQL Server 2005 DB, and Jira 7.7 requires SQL Server 2008 or above. We backed up our 2005 DB and then restored a new DB on a 2008 SQL Server instance from the 2005 backup . Then we upgraded Jira to 7.7 using the installer. We had to modify dbconfig.xml manually to use a SQL Server named instance since the browser startup page didn't seem to know how to connect to a named instance. The command prompt output says that the DB connection is OK.)
Now Jira won't start. In the command prompt output there are the following errors:
ERROR [o.e.g.b.e.i.util.concurrent.RunnableTimedExecution] Closing runnable for context NonValidatingOsgiBundleXmlApplicationContext(bundle=com.kintosoft.jira.subversion-plus, config=osgibundle:/META-INF/spring/*.xml) did not finish in 10000ms; conside
r taking a snapshot and then shutdown the VM in case the thread still hangs
2018-01-24 09:48:17,707 ThreadPoolAsyncTaskExecutor::Thread 13...
ERROR [o.e.g
.b.e.internal.support.ExtenderConfiguration] Application context refresh failed
(NonValidatingOsgiBundleXmlApplicationContext(bundle=com.kintosoft.jira.subversi
on-plus, config=osgibundle:/META-INF/spring/*.xml))
java.lang.NoClassDefFoundError: org/quartz/SchedulerException
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
at java.lang.Class.getDeclaredMethods(Class.java:1975)
at org.springframework.util.ReflectionUtils.getDeclaredMethods(Reflectio
nUtils.java:609)...
ERROR [c.a.u.l.storage.lib.PluginLicenseStoragePluginInstaller] Failed to install or enable
the Plugin License Storage plugin version 2.9.3
java.lang.NoSuchMethodError: com.google.common.collect.MapMaker.expiration(JLjav
a/util/concurrent/TimeUnit;)Lcom/google/common/collect/MapMaker;
at com.atlassian.upm.Functions.<clinit>(Functions.java:121)
at com.atlassian.upm.Functions$CachedFunction2.cache(Functions.java:170)...
ERROR [c.a.jira.index.LuceneCorruptionChecker] Can't open index 'C:\Program Files\Atlassian\Application Data\JIRA\ca
ches\indexes\plugins\kintosoft_subversion_h2'. Reason:
org.apache.lucene.index.IndexNotFoundException: no segments* file found in org.a
pache.lucene.store.MMapDirectory@C:\Program Files\Atlassian\Application Data\JIR
A\caches\indexes\plugins\kintosoft_subversion_h2 lockFactory=com.atlassian.jira.
util.LuceneDirectoryUtilsImpl$UtilConcurrentLockFactory@10d8c2cf: files: [index.
h2.db, index.trace.db]
at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfo
s.java:708)...
ERROR [c.a.upgrade.core.DefaultUpgradeTaskFactoryProcessor] Upgrade task [host,buildNumber=70024] failed java.lang.RuntimeException: Error running original upgrade task at com.atlassian.jira.upgrade.AbstractUpgradeTask.runUpgrade(AbstractUpg
radeTask.java:63)...
In User Plugins, Subvesion ALM seems to be the only disabled plugin, and there is a Failed Plugin Report at the end of the command prompt output:
1 plugin failed to load during JIRA startup. 'com.kintosoft.jira.subversion-plus' - 'Subversion ALM' failed to load. org/quartz/SchedulerException org.quartz.SchedulerException not found by com.kintosoft.jira.subversion-plus [181] It was loaded from C:\Program Files\Atlassian\Application Data\J
IRA\plugins\installed-plugins\plugin.437050540674858826.subversion-plus-6.0.10-j
ira-6.jar
Is the Subversion ALM plugin causing JIRA not to start? (a lot of the errors seem to be about it) And if so, how can we fix this?
Thanks.