I initially installed JIRA using the internal db for evaluation. We have started using the product and purchased a 10 user licence, with plans to expand shortly. Once I added my licence to JIRA, it gave me a warning that I should migrate to an external db.
I am following the guide here;
https://confluence.atlassian.com/adminjiraserver071/switching-databases-802592192.html
Specifically; Migrating JIRA's data to a different type of database server.
I created my back up, shutdown, removed the dbconfig, restarted, walked through the connection wizard, and established my connection.
But then JIRA just errors out.
I can see that the tables were created in the db. But JIRA does not start.
If I replace the new dbconfig with the old, it restarts just fine.
But I am not sure how to trouble shoot the SQL issue.
See the error log; https://pastebin.com/raw/qzgFcSqu