Hello,
After every start up of our jira server we get some errors that some, even important plugins, can't be loaded. We get the following error message.
5 plugins failed to load during JIRA startup.
'com.atlassian.servicedesk.project-ui' - 'JIRA Service Desk Project Plugin' failed to load.
Failed to parse configuration class [com.atlassian.servicedesk.project.internal.web.action.ProjectApplicationAction]; nested exception is java.io.FileNotFoundException: class path resource [co
m/atlassian/jira/web/util/AuthorizationSupport.class] cannot be opened because it does not exist
class path resource [com/atlassian/jira/web/util/AuthorizationSupport.class] cannot be opened because it does not exist
It was loaded from /var/atlassian/application-data/jira/plugins/installed-plugins/servicedesk-project-ui-plugin-3.0.9.jar
'com.pyxis.greenhopper.jira' - 'JIRA Agile' failed to load.
The plugin has been disabled. A likely cause is that it timed out during initialisation
It has the following missing service dependencies :
&pluginLicenseEventRegistry of type (objectClass=com.atlassian.upm.api.license.PluginLicenseEventRegistry)
&pluginLicenseManager of type (objectClass=com.atlassian.upm.api.license.PluginLicenseManager)
It was loaded from /var/atlassian/application-data/jira/plugins/installed-plugins/jira-greenhopper-plugin-7.4.0-DAILY20170620023133.jar
'com.atlassian.servicedesk.plugins.automation.servicedesk-automation-modules-plugin' - 'Service Desk Automation Modules Plugin' failed to load.
The plugin has been disabled. A likely cause is that it timed out during initialisation
It has the following missing service dependencies :
&requestTypeService of type (&(objectClass=com.atlassian.servicedesk.api.requesttype.RequestTypeService)(objectClass=com.atlassian.servicedesk.api.requesttype.RequestTypeService))
&serviceDeskLicenseService of type (&(objectClass=com.atlassian.servicedesk.api.license.ServiceDeskLicenseService)(objectClass=com.atlassian.servicedesk.api.license.ServiceDeskLicense
Service))
&serviceDeskService of type (&(objectClass=com.atlassian.servicedesk.api.ServiceDeskService)(objectClass=com.atlassian.servicedesk.api.ServiceDeskService))
&serviceDeskCommentService of type (&(objectClass=com.atlassian.servicedesk.api.comment.ServiceDeskCommentService)(objectClass=com.atlassian.servicedesk.api.comment.ServiceDeskComment
Service))
&serviceDeskPermissionService of type (&(objectClass=com.atlassian.servicedesk.api.permission.ServiceDeskPermissionService)(objectClass=com.atlassian.servicedesk.api.permission.Servic
eDeskPermissionService))
&portalService of type (&(objectClass=com.atlassian.servicedesk.api.portal.PortalService)(objectClass=com.atlassian.servicedesk.api.portal.PortalService))
&serviceDeskManager of type (&(objectClass=com.atlassian.servicedesk.api.ServiceDeskManager)(objectClass=com.atlassian.servicedesk.api.ServiceDeskManager))
&serviceDeskCustomerRequestService of type (&(objectClass=com.atlassian.servicedesk.api.request.ServiceDeskCustomerRequestService)(objectClass=com.atlassian.servicedesk.api.request.Se
rviceDeskCustomerRequestService))
It was loaded from /var/atlassian/application-data/jira/plugins/installed-plugins/servicedesk-automation-modules-plugin-1.2.12.jar
'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' - 'Atlassian Universal Plugin Manager Plugin' failed to load.
Error creating bean with name 'disallowStartupInCloud' defined in URL [bundle://177.0:0/META-INF/spring/atlassian-plugins-components.xml]: Instantiation of bean failed; nested exception is org
.springframework.beans.BeanInstantiationException: Failed to instantiate [com.atlassian.upm.DisallowStartupInCloud]: Constructor threw exception; nested exception is java.lang.IllegalStateException: this Serv
er version of UPM cannot be used in a Cloud environment
Failed to instantiate [com.atlassian.upm.DisallowStartupInCloud]: Constructor threw exception; nested exception is java.lang.IllegalStateException: this Server version of UPM cannot be
used in a Cloud environment
this Server version of UPM cannot be used in a Cloud environment
It was loaded from /var/atlassian/application-data/jira/plugins/installed-plugins/plugin.8608492972167793158.atlassian-universal-plugin-manager-plugin-2.22.3.jar
'com.atlassian.servicedesk' - 'JIRA Service Desk' failed to load.
The plugin has been disabled. A likely cause is that it timed out during initialisation
It has the following missing service dependencies :
&pluginLicenseManager of type (&(objectClass=com.atlassian.upm.api.license.PluginLicenseManager)(objectClass=com.atlassian.upm.api.license.PluginLicenseManager))
&pluginLicenseEventRegistry of type (&(objectClass=com.atlassian.upm.api.license.PluginLicenseEventRegistry)(objectClass=com.atlassian.upm.api.license.PluginLicenseEventRegistry))
It was loaded from /var/atlassian/application-data/jira/plugins/installed-plugins/jira-servicedesk-3.0.9.jar