I have a JIRA instance running on the production server . It randomly stops working at times and we need to enter the Production server and start the service .
I need to know:
why this happens and what's the workaround this issue?
The logs have been added for the last three shutdowns I had(7th April,21 april & 12th June), please look into this and let me know the issue and its solution.
7th april friday
2017-04-07 01:21:36,382 http-bio-8080-exec-312 WARN <username> 81x605019x1 1x43ivl <ipaddress>/secure/TempoUserBoard!timesheet.jspa [atlassian.upm.pac.PacClientImpl] Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException$ConnectionFailure: org.apache.http.conn.HttpHostConnectException: Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/10.xxx.xxx.xx, marketplace.atlassian.com/104.xxx.xxx.xx, marketplace.atlassian.com/104.xxx.xxx.xx] failed: Connection refused: connect
2017-04-07 04:55:58,014 localhost-startStop-1 INFO [atlassian.jira.startup.JiraStartupLogger]
****************
JIRA starting...
****************
2017-04-07 04:55:58,250 localhost-startStop-1 INFO [atlassian.jira.startup.JiraStartupLogger]
___ Environment _____________________________
JIRA Build : 6.4.7#64022-sha1:4cb296803939f4a073aa3b93ab6313ffa6c86a2e
Build Date : Tue Jun 16 00:00:00 CDT 2015
JIRA Installation Type : Standalone
Application Server : Apache Tomcat/7.0.55 - Servlet API 3.0
Java Version : 1.8.0_91 - Oracle Corporation
Current Working Directory : C:\Program Files\Atlassian\JIRA
Maximum Allowable Memory : 683MB
Total Memory : 389MB
Free Memory : 228MB
Used Memory : 161MB
Memory Pool: Code Cache : Code Cache: init = 2555904(2496K) used = 9178816(8963K) committed = 9699328(9472K) max = 251658240(245760K)
Memory Pool: Metaspace : Metaspace: init = 0(0K) used = 18289704(17861K) committed = 18874368(18432K) max = -1(-1K)
Memory Pool: Compressed Class Space : Compressed Class Space: init = 0(0K) used = 2166336(2115K) committed = 2359296(2304K) max = 1073741824(1048576K)
Memory Pool: PS Eden Space : PS Eden Space: init = 67108864(65536K) used = 80965056(79067K) committed = 188743680(184320K) max = 188743680(184320K)
Memory Pool: PS Survivor Space : PS Survivor Space: init = 11010048(10752K) used = 25571280(24971K) committed = 39845888(38912K) max = 39845888(38912K)
Memory Pool: PS Old Gen : PS Old Gen: init = 179306496(175104K) used = 61746680(60299K) committed = 179306496(175104K) max = 536870912(524288K)
JVM Input Arguments : -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -Dcatalina.home=C:\Program Files\Atlassian\JIRA -Dcatalina.base=C:\Program Files\Atlassian\JIRA -Djava.endorsed.dirs=C:\Program Files\Atlassian\JIRA\endorsed -Djava.io.tmpdir=C:\Program Files\Atlassian\JIRA\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Program Files\Atlassian\JIRA\conf\logging.properties -XX:MaxPermSize=384m exit -Xms256m -Xmx768m
Java Compatibility Information : JIRA version = 6.4.7, Java Version = 1.8.0_91
------------------------------------------
21 april 2017
2017-04-21 01:24:46,521 http-bio-8080-exec-123 WARN <username>84x268756x1 lzvz9i <ipaddress>/secure/TempoUserBoard!timesheet.jspa [atlassian.upm.pac.PacClientImpl] Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException$ConnectionFailure: org.apache.http.conn.HttpHostConnectException: Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/104.xxx.xxx.xxmarketplace.atlassian.com/104.xxx.xxx.xx, marketplace.atlassian.com/104.xxx.xxx.xx] failed: Connection refused: connect
2017-04-21 06:00:52,535 localhost-startStop-1 INFO [atlassian.jira.startup.JiraStartupLogger]
****************
JIRA starting...
****************
2017-04-21 06:00:52,775 localhost-startStop-1 INFO [atlassian.jira.startup.JiraStartupLogger]
-----------------------------------------------------------------------------------------