Issue index is inconsistent with the database state. Database has (95,542) issues but the index has (62,541) issues.
Problem solved.
We took a look at the logs again and found out that the was a value conversions problem. This info on this link below helps and updating JDK
https://confluence.atlassian.com/jirakb/re-index-fail-due-to-timestamp-conversion-issue-329355068.html
Currently running a server JIRA version 7.1.9 with less done 100k issues, but almost there.
Ok, if the indexing is still running, what is the problem?
JIRA is unable to perform a background re-index at this time because the index files are either missing or corrupted.
Instance HealthProblems DetectedError: IndexingError: LuceneThe issue index is inconsistent with the database state. Database has (95,542) issues but the index has (62,541) issues.When I run re-indexing, it fails at 64% due to the problem discription mentioned above.
I need help with resolve this
Can you try the below steps:-
1. Shutdown JIRA
2. Backup your Index folder
3. Go to Index Folder
4. Delete all index folders
5. Start JIRA
6. And perform re-indexing.
If this doesn't fix it, you can always copy the backed up index folder.
Tried this yesterday and still having the same problem. Re-indexing is failing at the same point before and after deleting the index folders
Oh... I suggest to reach out to the support team with support zip. They would analyse the logs and provide a solution.
It looks like you're new here. Sign in or register to get started.