After Implementation of SSL on JIRA version 7.0.10 we got Error "An internal server error occurred when requesting resource" while adding Version report Gadget on the dashboard
Please find attachment for your reference.
I suspect the system can't talk to itself over REST because of something not right in the SSL configuration, but if that's the case, I would expect other errors as well as this one.
You should read the log file to find out what the internal error is.
Hello Nic,
Thanks for the reply.
Please find below error details of the log file for your reference & let me know the root cause of this error.
2017-04-18 05:38:44,715 http-bio-443-exec-10 ERROR [renderer.internal.http.HttpClientFetcher] Unable to retrieve responsejavax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No X509TrustManager implementation available
One thing the Atlassian documentation for Apache HTTPS configuration misses is that you need to set the ServerName directive in your conf file to the same Fully Qualified Domain Name that you're using in the Base URL. That's one thing to try changing.
We are using default tomcat with JIRA and we use keystoreType="PKCS12" for SSL. There is no Apache HTTPS configuration so we have added the custom code in server.xml file and SSL is working for all other Gadgets but only problem to Version report Gadget.
So please provide me any other soultion on it
I assumed you were using apache because you were listening on port 443. Are you on linux or windows? If linux, you must be running as root, which is not so great.
Why are you using a PKCS12 keystore rather than JKS as documentation suggests?
We are using windows machine with intranet and enabled the tomcat on 443 port. The PKCS12 key is created by our IT team and so we are using that key in configuration.
Do you know how to convert the PKCS12 keystore to JKS format ?
Please also provide the correct steps to enabled SSL on JIRA.
It looks like you're new here. Sign in or register to get started.