Hi I am getting below exception while configuring mailbox to jira.
Unable to connect to the server at <exchange server host name> due to the following exception: java.net.ConnectException: Connection refused
That means your JIRA server cannot get a connection to the mail server.
Check the network allows the connection, that the mail server is running on the server and ports given, and that your credentials are correct.
Check with Network team There is actually a error code received in response for any connection refused.
You should be easily able to identify the cause seeing the error code.
thanks sumit ,
i am able to ping the exchange server from JIRA server. but still getting same error.
Hi Nic,
Thanks for your reply , i am able to ping Exchange server from JIRA server and also I am able to login to mailbox with given credentials.
Good start, but you need to test the whole connection. Ping tests a port and a service, and only really tests the route and that the server is running with something that responds to ping. You're using a totally different service - mail.
So, you need to test that. Ask your Exchange administrators for the port number they have chosen to run POP3 or IMAP on for you (more recent Exchange servers have those turned off in favour of the inferior MAPI protocol which is non-standard and not supportable, so you must have got one of them enabled to use with JIRA. I'd recommend secure-imap)
Thank you so much @Nic Brough [Adaptavist] , for your response ,
I had a discussion with my Exchange Administrator , and they are not ready to enable POP or IMAP protocol for just jira-mailbox. they are currently using SMTP protocol to send and receive the email.
They are telling that if we will change protocol from SMTP to IMAP or POP this will change whole organization structure and security.
so is there any workaround we can do here?
your help will be much appreciated.
It looks like you're new here. Sign in or register to get started.