Hi, I've already posted 2 questions - all of them being provoked by this error - I am trying to add a new user to Bitbucket and it says that "This account is already at its plan limit and will need to be upgraded before adding more users.".

I did reach a limit indeed but after seeing this error, I have deleted a user who is no longer a contributor, and re-tried a few times, seeing the same error. I've also reindexed Jira, which apparently has no effect on Bitbucket accounts.
Please help. And no, I do not want to upgrade if the issue is just a bug of not re-calculating number of users.