Trans un corte de servicio el JIRA arranca con este error
Estado HTTP 500 - Could not determine database type. (FATAL: database "jira" does not exist)
type Informe de Excepción
mensaje Could not determine database type. (FATAL: database "jira" does not exist)
descripción El servidor encontró un error interno que hizo que no pudiera rellenar este requerimiento.
excepción
org.ofbiz.core.util.GeneralRuntimeException: Could not determine database type. (FATAL: database "jira" does not exist)
org.ofbiz.core.entity.config.DatasourceInfo.getDatabaseTypeFromJDBCConnection(DatasourceInfo.java:409)
org.ofbiz.core.entity.GenericDAO.selectListIteratorByCondition(GenericDAO.java:826)
org.ofbiz.core.entity.GenericDAO.selectByAnd(GenericDAO.java:725)
org.ofbiz.core.entity.GenericHelperDAO.findByAnd(GenericHelperDAO.java:150)
org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:901)
org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:879)
org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:848)
com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.findPropertyEntry(OFBizPropertySet.java:298)
com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.exists(OFBizPropertySet.java:170)
com.atlassian.jira.propertyset.JiraCachingPropertySet.exists(JiraCachingPropertySet.java:744)
com.atlassian.jira.propertyset.BootstrapOfBizPropertyEntryStore.getEntry(BootstrapOfBizPropertyEntryStore.java:60)
com.atlassian.jira.propertyset.CachingOfBizPropertySet.get(CachingOfBizPropertySet.java:196)
com.opensymphony.module.propertyset.AbstractPropertySet.getString(AbstractPropertySet.java:305)
com.atlassian.jira.config.properties.ApplicationPropertiesStore.getStringFromDb(ApplicationPropertiesStore.java:271)
com.atlassian.jira.config.properties.ApplicationPropertiesImpl.getString(ApplicationPropertiesImpl.java:56)
com.atlassian.jira.config.properties.ApplicationPropertiesImpl.getEncoding(ApplicationPropertiesImpl.java:119)
com.atlassian.jira.config.properties.ApplicationPropertiesImpl.getContentType(ApplicationPropertiesImpl.java:141)
com.atlassian.jira.web.filters.JiraEncodingFilter.getContentType(JiraEncodingFilter.java:59)
com.atlassian.core.filters.encoding.AbstractEncodingFilter.doFilter(AbstractEncodingFilter.java:39)
com.atlassian.core.filters.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:31)
com.atlassian.jira.web.filters.PathMatchingEncodingFilter.doFilter(PathMatchingEncodingFilter.java:49)
com.atlassian.core.filters.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:31)
com.atlassian.jira.startup.JiraStartupChecklistFilter.doFilter(JiraStartupChecklistFilter.java:79)
com.atlassian.jira.web.filters.MultipartBoundaryCheckFilter.doFilter(MultipartBoundaryCheckFilter.java:41)
com.atlassian.jira.web.filters.steps.ChainedFilterStepRunner.doFilter(ChainedFilterStepRunner.java:87)
com.atlassian.jira.web.filters.JiraFirstFilter.doFilter(JiraFirstFilter.java:60)
nota La traza completa de la causa de este error se encuentra en los archivos de diario de Apache Tomcat/7.0.55.
[root@jira]# more /var/lib/pgsql/data/pg_hba.conf
# TYPE DATABASE USER CIDR-ADDRESS METHOD
# "local" is for Unix domain socket connections only
local all all trust
# IPv4 local connections:
host all all 127.0.0.1/32 trust
# IPv6 local connections:
host all all ::1/128 ident
postgres=# \list
List of databases
Name | Owner | Encoding | Collation | Ctype | Access privileges
-----------+----------+----------+-------------+-------------+-----------------------
postgres | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 |
template0 | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 | =c/postgres
: postgres=CTc/postgres
template1 | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 | =c/postgres
: postgres=CTc/postgres
(3 rows)
postgres=# \du
List of roles
Role name | Attributes | Member of
-----------+-------------+-----------
postgres | Superuser | {}
: Create role
: Create DB