In Confluence 4.0 We added an LDAP directory which, for some reason, wiped out all our administrator rights. SQL srvr back-end
We can't log in as an admin.
Followed the instructions for: If No Local Users Exist
Was able to add an 'admin' to local
-
Add new groups by running: {ok}
-
Add group memberships into cwd_membership: 
Could not do. Duplicate key msg from SQL
- Add group memberships into cwd_membership:

We presume that 2 didn't happen because the memberships are already there.
But the admin we added via sql can't log in. The message on log-in says the user does not exist. The local confluence directory is order '0' and still can't log in. I set the LDAP to 'F' - no joy.
How do we fix that - get an admin authority or roll back or take that LDAP added directory out from Confluence from the back-end.
Any ideas?