We have a number of pipelines for different projects and it seems that since Friday the pipelines that uses a Docker image to perform integration test using Kafka now fails. They seem to fail with identical error messages.
[INFO] Running se.pilotfish.spartacus.repository.CustomerMasterRepositoryIntegrationTest
2025-06-16 06:35:44.532 WARN --- [ main] o.t.utility.TestcontainersConfiguration : Attempted to read Testcontainers configuration file at file:/root/.testcontainers.properties but the file was not found. Exception message: FileNotFoundException: /root/.testcontainers.properties (No such file or directory)
2025-06-16 06:35:46.960 WARN --- [ main] o.testcontainers.utility.ResourceReaper :
********************************************************************************
Ryuk has been disabled. This can cause unexpected behavior in your environment.
********************************************************************************
2025-06-16 06:36:13.500 WARN --- [ntainers-wait-0] .c.w.i.InternalCommandPortListeningCheck : An exception while executing the internal check: Container.ExecResult(exitCode=137, stdout=, stderr=Ncat: Version 7.92 ( https://nmap.org/ncat )
Ncat: Connection to 127.0.0.1 failed: Connection refused.
Ncat: Trying next address...
Ncat: Cannot assign requested address.
/bin/bash: connect: Cannot assign requested address
/bin/bash: line 1: /dev/tcp/localhost/9093: Cannot assign requested address
Ncat: Version 7.92 ( https://nmap.org/ncat )
Ncat: Connection to 127.0.0.1 failed: Connection refused.
Ncat: Trying next address...
Ncat: Cannot assign requested address.
/bin/bash: connect: Cannot assign requested address
/bin/bash: line 1: /dev/tcp/localhost/9093: Cannot assign requested address
Ncat: Version 7.92 ( https://nmap.org/ncat )
Ncat: Connection to 127.0.0.1 failed: Connection refused.
Ncat: Trying next address...
Ncat: Cannot assign requested address.
/bin/bash: connect: Cannot assign requested address
/bin/bash: line 1: /dev/tcp/localhost/9093: Cannot assign requested address
)
2025-06-16 06:36:13.625 ERROR --- [ main] 🐳 [confluentinc/cp-kafka:latest] : Could not start container
com.github.dockerjava.api.exception.ConflictException: Status 409: {"message":"container d397985de3ebc83b48ca33f296a3d11cd864ad70fc361d8e0d0e03d09461b478 is not running"}