Hello,
I am experiencing an interesting issue. When I'm adding a known hosts under Pipelines > SSH Keys, the fingerprint is not the same and only rarely I get the correct fingerprint. From my testing, it looks like a hit-and-miss approach, since I'm not changing anything on my end and server is no behind firewall, but from 30 "Fetch" known hosts fingerprint, I may get 1 that is correct. I'm also getting up to three different fingerprints for the same host and don't know why.
The problem is that when I'm using Pipelines for deployment, I get a big red error in those that "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!". But it didn't, the fingerprint obtained was wrong in the first place. After I fetch the correct key, everything works correctly.
Any ideas?